summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ethtool
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2023-01-13 15:56:54 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-01-15 08:46:07 +0000
commitf0090883eb66a636f9737cb1a09eee5dbea27883 (patch)
tree83bf07608448b6307193260c6c27770642006e5b /meta/recipes-extended/ethtool
parent93287c629e889d8026f76a42646bbe4529a7523f (diff)
downloadopenembedded-core-f0090883eb66a636f9737cb1a09eee5dbea27883.tar.gz
ethtool: upgrade 6.0 -> 6.1
Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ethtool')
-rw-r--r--meta/recipes-extended/ethtool/ethtool/0001-marvell.c-define-_GNU_SOURCE.patch59
-rw-r--r--meta/recipes-extended/ethtool/ethtool/avoid_parallel_tests.patch6
-rw-r--r--meta/recipes-extended/ethtool/ethtool_6.1.bb (renamed from meta/recipes-extended/ethtool/ethtool_6.0.bb)3
3 files changed, 64 insertions, 4 deletions
diff --git a/meta/recipes-extended/ethtool/ethtool/0001-marvell.c-define-_GNU_SOURCE.patch b/meta/recipes-extended/ethtool/ethtool/0001-marvell.c-define-_GNU_SOURCE.patch
new file mode 100644
index 0000000000..8a7eeafb9c
--- /dev/null
+++ b/meta/recipes-extended/ethtool/ethtool/0001-marvell.c-define-_GNU_SOURCE.patch
@@ -0,0 +1,59 @@
+From 5112785191e3279c671a027fe797be77e1071ecd Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex@linutronix.de>
+Date: Mon, 2 Jan 2023 13:45:46 +0100
+Subject: [PATCH] marvell.c: use portable integer types
+
+u_int32_t is not portable, but uint32_t is.
+
+Upstream-Status: Submitted [by email to mkubecek@suse.cz]
+Signed-off-by: Alexander Kanavin <alex@linutronix.de>
+
+---
+ marvell.c | 34 +++++++++++++++++-----------------
+ 1 file changed, 17 insertions(+), 17 deletions(-)
+
+diff --git a/marvell.c b/marvell.c
+index d3d570e..3d42eed 100644
+--- a/marvell.c
++++ b/marvell.c
+@@ -31,23 +31,23 @@ static void dump_timer(const char *name, const void *p)
+ static void dump_queue(const char *name, const void *a, int rx)
+ {
+ struct desc {
+- u_int32_t ctl;
+- u_int32_t next;
+- u_int32_t data_lo;
+- u_int32_t data_hi;
+- u_int32_t status;
+- u_int32_t timestamp;
+- u_int16_t csum2;
+- u_int16_t csum1;
+- u_int16_t csum2_start;
+- u_int16_t csum1_start;
+- u_int32_t addr_lo;
+- u_int32_t addr_hi;
+- u_int32_t count_lo;
+- u_int32_t count_hi;
+- u_int32_t byte_count;
+- u_int32_t csr;
+- u_int32_t flag;
++ uint32_t ctl;
++ uint32_t next;
++ uint32_t data_lo;
++ uint32_t data_hi;
++ uint32_t status;
++ uint32_t timestamp;
++ uint16_t csum2;
++ uint16_t csum1;
++ uint16_t csum2_start;
++ uint16_t csum1_start;
++ uint32_t addr_lo;
++ uint32_t addr_hi;
++ uint32_t count_lo;
++ uint32_t count_hi;
++ uint32_t byte_count;
++ uint32_t csr;
++ uint32_t flag;
+ };
+ const struct desc *d = a;
+
diff --git a/meta/recipes-extended/ethtool/ethtool/avoid_parallel_tests.patch b/meta/recipes-extended/ethtool/ethtool/avoid_parallel_tests.patch
index c3cefbb5e6..4994369682 100644
--- a/meta/recipes-extended/ethtool/ethtool/avoid_parallel_tests.patch
+++ b/meta/recipes-extended/ethtool/ethtool/avoid_parallel_tests.patch
@@ -1,4 +1,4 @@
-From dea90ab711acad251b5d8536c534409979ea8be4 Mon Sep 17 00:00:00 2001
+From 0d066a901292e6a44ff7bc7ee16f99dd2ba4ea15 Mon Sep 17 00:00:00 2001
From: Tudor Florea <tudor.florea@enea.com>
Date: Wed, 28 May 2014 18:59:54 +0200
Subject: [PATCH] ethtool: use serial-tests config needed by ptest.
@@ -15,11 +15,11 @@ Upstream-Status: Inappropriate
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
-index 89d0e70..ab2be9c 100644
+index 3eb4e7b..ee5c72f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@ dnl Process this file with autoconf to produce a configure script.
- AC_INIT(ethtool, 6.0, netdev@vger.kernel.org)
+ AC_INIT(ethtool, 6.1, netdev@vger.kernel.org)
AC_PREREQ(2.52)
AC_CONFIG_SRCDIR([ethtool.c])
-AM_INIT_AUTOMAKE([gnu subdir-objects])
diff --git a/meta/recipes-extended/ethtool/ethtool_6.0.bb b/meta/recipes-extended/ethtool/ethtool_6.1.bb
index 8f36520b00..2b9bbe69db 100644
--- a/meta/recipes-extended/ethtool/ethtool_6.0.bb
+++ b/meta/recipes-extended/ethtool/ethtool_6.1.bb
@@ -9,9 +9,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \
file://run-ptest \
file://avoid_parallel_tests.patch \
+ file://0001-marvell.c-define-_GNU_SOURCE.patch \
"
-SRC_URI[sha256sum] = "f2168e2b45d7e58ed5b76e5533fd607ca0720c9e631f4271bfe997bf72330796"
+SRC_URI[sha256sum] = "1d03f1ce324fbd95591191c42ac0c4c9cc721e067b929083a20a46c4b4731436"
UPSTREAM_CHECK_URI = "https://www.kernel.org/pub/software/network/ethtool/"