summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/cronie/cronie_1.4.6.bb
diff options
context:
space:
mode:
authorSaul Wold <Saul.Wold@intel.com>2010-11-24 12:31:00 -0800
committerSaul Wold <Saul.Wold@intel.com>2010-11-24 13:25:21 -0800
commit50940748998d5a5e8ca2d582ba5790c3f1c40eec (patch)
treea7801d1db6ee17e3e06ec9343fc0d887889b0049 /meta/recipes-extended/cronie/cronie_1.4.6.bb
parent333ca679f2757ab7a15e3dc0be4c3a9371aeb20d (diff)
downloadopenembedded-core-50940748998d5a5e8ca2d582ba5790c3f1c40eec.tar.gz
cronie: Update to version 1.4.6
Signed-off-by: Saul Wold <Saul.Wold@intel.com>
Diffstat (limited to 'meta/recipes-extended/cronie/cronie_1.4.6.bb')
-rw-r--r--meta/recipes-extended/cronie/cronie_1.4.6.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-extended/cronie/cronie_1.4.6.bb b/meta/recipes-extended/cronie/cronie_1.4.6.bb
new file mode 100644
index 0000000000..e9b146b894
--- /dev/null
+++ b/meta/recipes-extended/cronie/cronie_1.4.6.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Cronie contains the standard UNIX daemon crond that runs \
+specified programs at scheduled times and related tools. It is based on the \
+original cron and has security and configuration enhancements like the \
+ability to use pam and SELinux."
+HOMEPAGE = "https://fedorahosted.org/cronie/"
+BUGTRACKER = "mmaslano@redhat.com"
+
+# Internet Systems Consortium License
+LICENSE = "ISC license & BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=963ea0772a2adbdcd607a9b2ec320c11 \
+ file://src/cron.h;endline=20;md5=b425c334265026177128353a142633b4 \
+ file://src/popen.c;beginline=3;endline=31;md5=edd50742d8def712e9472dba353668a9"
+
+SECTION = "utils"
+
+PR = "r0"
+
+SRC_URI = "https://fedorahosted.org/releases/c/r/cronie/cronie-${PV}.tar.gz \
+ file://crond.init"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "crond"
+INITSCRIPT_PARAMS = "start 90 2 3 4 5 . stop 60 0 1 6 ."
+
+do_install_append () {
+ install -d ${D}${sysconfdir}/sysconfig/
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0644 ${S}/crond.sysconfig ${D}${sysconfdir}/sysconfig/crond
+ install -m 0755 ${WORKDIR}/crond.init ${D}${sysconfdir}/init.d/crond
+}