summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-13 23:40:29 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-14 09:49:55 +0100
commit119ef2789484222b94559675a09adc399f3b6bf0 (patch)
tree7e05407b0f2800320f220263a387935f704c6b87 /meta/recipes-devtools
parent312efe73dad8a9baf32578bd11a1654219d759df (diff)
downloadopenembedded-core-119ef2789484222b94559675a09adc399f3b6bf0.tar.gz
opkg: Fix package dependency issue for preinsts
When processing dependencies, we need to look for both the SW_INSTALL and SW_UNKNOWN states. If we don't do this, dependencies can be missed and preinst scripts can run before dependencies are all installed. This leads to package installation errors for packages like dbus-1 and associated user permission errors. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/opkg/opkg/fix_installorder.patch2
-rw-r--r--meta/recipes-devtools/opkg/opkg_svn.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/opkg/opkg/fix_installorder.patch b/meta/recipes-devtools/opkg/opkg/fix_installorder.patch
index 9dd10b28e1..6a7e6dbb4b 100644
--- a/meta/recipes-devtools/opkg/opkg/fix_installorder.patch
+++ b/meta/recipes-devtools/opkg/opkg/fix_installorder.patch
@@ -147,7 +147,7 @@ Index: trunk/libopkg/pkg_depends.c
+ dependence_to_satisfy, 0);
+ /* Being that I can't test constraing in pkg_hash, I will test it here */
+ if (satisfying_pkg != NULL && satisfying_pkg != pkg) {
-+ if (pkg_constraint_satisfied(satisfying_pkg, dependence_to_satisfy) && satisfying_pkg->state_want == SW_INSTALL)
++ if (pkg_constraint_satisfied(satisfying_pkg, dependence_to_satisfy) && (satisfying_pkg->state_want == SW_INSTALL || satisfying_pkg->state_want == SW_UNKNOWN))
+ pkg_vec_insert(satisfiers, satisfying_pkg);
+ }
+
diff --git a/meta/recipes-devtools/opkg/opkg_svn.bb b/meta/recipes-devtools/opkg/opkg_svn.bb
index a0667ac6fe..4146b7e018 100644
--- a/meta/recipes-devtools/opkg/opkg_svn.bb
+++ b/meta/recipes-devtools/opkg/opkg_svn.bb
@@ -14,4 +14,4 @@ S = "${WORKDIR}/trunk"
SRCREV = "633"
PV = "0.1.8+svnr${SRCPV}"
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"