summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu/nativesdk-qemu-helper_1.0.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2024-04-25 17:01:30 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-04-26 22:11:31 +0100
commitf9eb589876040ead91c51d7f56933c1771c4c523 (patch)
treec17f260e185af0ce151b0a6f3ba4e993e303c016 /meta/recipes-devtools/qemu/nativesdk-qemu-helper_1.0.bb
parent853ba9faccd53e1bcc3f899bdbfd5ebdea389a3f (diff)
downloadopenembedded-core-master-next.tar.gz
recipes: Avoid S = WORKDIRmaster-next
Where recipes use S = ${WORKDIR}, change them to set UNPACKDIR to a subdir of WORKDIR and make S point at this instead. Where WORKDIR is referenced in do_compile/do_install and similar, switch to using ${S} which conceptually makes more sense. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/qemu/nativesdk-qemu-helper_1.0.bb')
-rw-r--r--meta/recipes-devtools/qemu/nativesdk-qemu-helper_1.0.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta/recipes-devtools/qemu/nativesdk-qemu-helper_1.0.bb b/meta/recipes-devtools/qemu/nativesdk-qemu-helper_1.0.bb
index 5d40784201..90bba84b03 100644
--- a/meta/recipes-devtools/qemu/nativesdk-qemu-helper_1.0.bb
+++ b/meta/recipes-devtools/qemu/nativesdk-qemu-helper_1.0.bb
@@ -18,7 +18,8 @@ SRC_URI = "file://${COREBASE}/scripts/runqemu \
file://${COREBASE}/scripts/runqemu-export-rootfs \
"
-S = "${WORKDIR}"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
inherit nativesdk
@@ -28,6 +29,6 @@ do_compile() {
do_install() {
install -d ${D}${bindir}
- install -m 0755 ${WORKDIR}${COREBASE}/scripts/oe-* ${D}${bindir}/
- install -m 0755 ${WORKDIR}${COREBASE}/scripts/runqemu* ${D}${bindir}/
+ install -m 0755 ${S}${COREBASE}/scripts/oe-* ${D}${bindir}/
+ install -m 0755 ${S}${COREBASE}/scripts/runqemu* ${D}${bindir}/
}