summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-mako_1.3.2.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-02-02 08:08:33 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-02-14 13:52:20 +0000
commit6cc0e19da1259b4461e6b9c7014ab041b9d60fa4 (patch)
tree3900609a467ac0f9f3c493907d1ec016d722145d /meta/recipes-devtools/python/python3-mako_1.3.2.bb
parent3752a33ce9490d8fc9d59a0e952faa47c0abba71 (diff)
downloadopenembedded-core-6cc0e19da1259b4461e6b9c7014ab041b9d60fa4.tar.gz
python3-mako: upgrade 1.3.0 -> 1.3.2
Bugfix: --------- Fixed parsing issue where attempting to render a single percent sign % using an escaped percent %% would not function correctly if the escaped percent were not the first character on a line. License-Update: Copyright year updated to 2024. Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
Diffstat (limited to 'meta/recipes-devtools/python/python3-mako_1.3.2.bb')
-rw-r--r--meta/recipes-devtools/python/python3-mako_1.3.2.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-mako_1.3.2.bb b/meta/recipes-devtools/python/python3-mako_1.3.2.bb
new file mode 100644
index 0000000000..c3391a6030
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-mako_1.3.2.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Templating library for Python"
+HOMEPAGE = "http://www.makotemplates.org/"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d0995d6f7ba3f186a03118f244e88f57"
+
+PYPI_PACKAGE = "Mako"
+
+inherit pypi python_setuptools_build_meta
+
+SRC_URI[sha256sum] = "2a0c8ad7f6274271b3bb7467dd37cf9cc6dab4bc19cb69a4ef10669402de698e"
+
+RDEPENDS:${PN} = "${PYTHON_PN}-html \
+ ${PYTHON_PN}-markupsafe \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-pygments \
+ ${PYTHON_PN}-threading \
+"
+
+BBCLASSEXTEND = "native nativesdk"