summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-click_8.1.7.bb
diff options
context:
space:
mode:
authorSamantha Jalabert <samantha.jalabert@syslinbit.com>2023-09-22 14:46:18 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-09-27 11:47:36 +0100
commit05eb1b2feff36ab7d1525febf644316bd57a1299 (patch)
tree23ab95f18770ead3106d74fef5494c2bd686ea75 /meta/recipes-devtools/python/python3-click_8.1.7.bb
parent432d75629297c53a87195d74a722df09511011ab (diff)
downloadopenembedded-core-05eb1b2feff36ab7d1525febf644316bd57a1299.tar.gz
python3-click: Copy recipe from meta-python
commit: 1a14a28f132a10e9db7b3e5bb2b5361c4679946e Signed-off-by: Marta Rybczynska <mrybczynska@syslinbit.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-click_8.1.7.bb')
-rw-r--r--meta/recipes-devtools/python/python3-click_8.1.7.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-click_8.1.7.bb b/meta/recipes-devtools/python/python3-click_8.1.7.bb
new file mode 100644
index 0000000000..a4ec6cd1ef
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-click_8.1.7.bb
@@ -0,0 +1,39 @@
+SUMMARY = "A simple wrapper around optparse for powerful command line utilities."
+DESCRIPTION = "\
+Click is a Python package for creating beautiful command line interfaces \
+in a composable way with as little code as necessary. It's the "Command \
+Line Interface Creation Kit". It's highly configurable but comes with \
+sensible defaults out of the box."
+HOMEPAGE = "http://click.pocoo.org/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=1fa98232fd645608937a0fdc82e999b8"
+
+SRC_URI[sha256sum] = "ca9853ad459e787e2192211578cc907e7594e294c7ccc834310722b41b9ca6de"
+
+inherit pypi setuptools3 ptest
+
+SRC_URI += "file://run-ptest"
+
+RDEPENDS:${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+ ${PYTHON_PN}-terminal \
+ ${PYTHON_PN}-unixadmin \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+ cp -rf ${S}/setup.cfg ${D}${PTEST_PATH}/
+ cp -rf ${S}/docs ${D}${PTEST_PATH}/
+}
+
+UPSTREAM_CHECK_REGEX = "click/(?P<pver>\d+(\.\d+)+)/"
+
+CLEANBROKEN = "1"
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-threading \
+ "
+
+BBCLASSEXTEND = "native nativesdk"