summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-setuptools_28.8.0.bb
diff options
context:
space:
mode:
authorEdwin Plauchu <edwin.plauchu.camacho@linux.intel.com>2016-11-17 16:32:46 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-30 15:47:10 +0000
commitf3d565e9dadfdafd32252f3904594cae86492c41 (patch)
tree929988880faf413c969518d4434556ae82ed7ca9 /meta/recipes-devtools/python/python-setuptools_28.8.0.bb
parent0f53db8a63ed35031b1fcc85057b39ad43c9abd1 (diff)
downloadopenembedded-core-f3d565e9dadfdafd32252f3904594cae86492c41.tar.gz
python3-setuptools: upgrade to 28.8.0
It is a simultaneous upgrade for python 2 and 3 over setuptools. Signed-off-by: Edwin Plauchu <edwin.plauchu.camacho@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python-setuptools_28.8.0.bb')
-rw-r--r--meta/recipes-devtools/python/python-setuptools_28.8.0.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-setuptools_28.8.0.bb b/meta/recipes-devtools/python/python-setuptools_28.8.0.bb
new file mode 100644
index 0000000000..526474c7ea
--- /dev/null
+++ b/meta/recipes-devtools/python/python-setuptools_28.8.0.bb
@@ -0,0 +1,38 @@
+require python-setuptools.inc
+
+PROVIDES = "python-distribute"
+
+DEPENDS += "python"
+DEPENDS_class-native += "python-native"
+
+inherit distutils
+
+DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${PYTHON_SITEPACKAGES_DIR}"
+
+RDEPENDS_${PN} = "\
+ python-stringold \
+ python-email \
+ python-shell \
+ python-distutils \
+ python-compression \
+ python-pkgutil \
+ python-plistlib \
+ python-numbers \
+ python-html \
+ python-netserver \
+ python-ctypes \
+ python-subprocess \
+ python-unittest \
+ python-compile \
+"
+
+RDEPENDS_${PN}_class-native = "\
+ python-distutils \
+ python-compression \
+"
+
+RREPLACES_${PN} = "python-distribute"
+RPROVIDES_${PN} = "python-distribute"
+RCONFLICTS_${PN} = "python-distribute"
+
+BBCLASSEXTEND = "native nativesdk"