summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/prelink/prelink_git.bb
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2021-08-16 10:09:10 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-08-17 09:52:18 +0100
commitd25b644741f5b941aa3051545e86e16a365c51c3 (patch)
tree77db91ef65724338877a0bdc076d5aee61e13911 /meta/recipes-devtools/prelink/prelink_git.bb
parentcd60f20fe40bba5b80ab604ee34fbf4ec2b0b4a2 (diff)
downloadopenembedded-core-d25b644741f5b941aa3051545e86e16a365c51c3.tar.gz
prelink: add PACKAGECONFIG for selinux
Add PACKAGECONFIG for selinux rather than disable it directly. This is useful for selinux distro feature. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/prelink/prelink_git.bb')
-rw-r--r--meta/recipes-devtools/prelink/prelink_git.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-devtools/prelink/prelink_git.bb b/meta/recipes-devtools/prelink/prelink_git.bb
index 78d4c71817..24713b61f8 100644
--- a/meta/recipes-devtools/prelink/prelink_git.bb
+++ b/meta/recipes-devtools/prelink/prelink_git.bb
@@ -48,9 +48,11 @@ inherit autotools
BBCLASSEXTEND = "native"
-EXTRA_OECONF = "--disable-selinux --with-pkgversion=${PV}-${PR} \
+EXTRA_OECONF = "--with-pkgversion=${PV}-${PR} \
--with-bugurl=http://bugzilla.yoctoproject.org/"
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux"
#
# For target prelink we need to ensure paths match the lib path layout