summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/prelink/prelink_git.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2018-10-11 12:06:53 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-10-12 08:44:05 +0100
commit7f5d6f6b70cb1eb486d3ff5c029fc3c6202fc826 (patch)
treec00d383606f444f2da23c61a5a8b33bf7d0c5173 /meta/recipes-devtools/prelink/prelink_git.bb
parent7257f209e317db62f92279fc2ff7d6d1e5eddf75 (diff)
downloadopenembedded-core-7f5d6f6b70cb1eb486d3ff5c029fc3c6202fc826.tar.gz
prelink: Fix Segmentation fault error when prelink qemu
The info->resolvetls might be NULL according to src/prelink.c: [snip] /* Dynamic linker does not depend on any other library, all symbols resolve to themselves with the exception of SHN_UNDEF symbols which resolve to 0. */ if (info->symtab[r_sym].st_shndx == SHN_UNDEF) { info->resolveent = NULL; info->resolvetls = NULL; [snip] So we must check it before use its members, otherwise, there might be Segmentation fault error. Fixed: MACHINE = "qemumips" IMAGE_INSTALL_append = " qemu" $ bitbake core-image-minimal [snip] | /path/to/qemumips-poky-linux/core-image-minimal/1.0-r0/temp/run.prelink_image.1000: line 111: 1010 Segmentation fault (core dumped) [snip] Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/prelink/prelink_git.bb')
-rw-r--r--meta/recipes-devtools/prelink/prelink_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/prelink/prelink_git.bb b/meta/recipes-devtools/prelink/prelink_git.bb
index 3f2a2e227d..b1261d5942 100644
--- a/meta/recipes-devtools/prelink/prelink_git.bb
+++ b/meta/recipes-devtools/prelink/prelink_git.bb
@@ -32,6 +32,7 @@ SRC_URI = "git://git.yoctoproject.org/prelink-cross.git;branch=cross_prelink_sta
file://prelink.cron.daily \
file://prelink.default \
file://macros.prelink \
+ file://0001-src-arch-mips.c-check-info-resolvetls-before-use-its.patch \
"
UPSTREAM_CHECK_COMMITS = "1"