summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl
diff options
context:
space:
mode:
authorDongxiao Xu <dongxiao.xu@intel.com>2011-08-03 23:19:34 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-08-03 18:05:32 +0100
commitaa8f6b64055c6576bcdb63d3bbf9ab47b87c0d59 (patch)
tree4227422e3d11961f2cad232f4866fbe33d2077ed /meta/recipes-devtools/perl
parent4a5cc82218fa730b898c553875accfeb6800f9a4 (diff)
downloadopenembedded-core-aa8f6b64055c6576bcdb63d3bbf9ab47b87c0d59.tar.gz
libxml-simple-perl: Use BBCLASSEXTEND insteand of *-native recipe
It's not appropriate to require xxx.bb in xxx-native.bb, causing that xxx-native depends on target recipe. Use BBCLASSEXTEND to solve this issue. Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl')
-rw-r--r--meta/recipes-devtools/perl/libxml-simple-perl-native_2.18.bb7
-rw-r--r--meta/recipes-devtools/perl/libxml-simple-perl_2.18.bb2
2 files changed, 2 insertions, 7 deletions
diff --git a/meta/recipes-devtools/perl/libxml-simple-perl-native_2.18.bb b/meta/recipes-devtools/perl/libxml-simple-perl-native_2.18.bb
deleted file mode 100644
index 3877d0bde1..0000000000
--- a/meta/recipes-devtools/perl/libxml-simple-perl-native_2.18.bb
+++ /dev/null
@@ -1,7 +0,0 @@
-SECTION = "libs"
-
-inherit native
-
-require libxml-simple-perl_${PV}.bb
-
-DEPENDS += "libxml-parser-perl-native"
diff --git a/meta/recipes-devtools/perl/libxml-simple-perl_2.18.bb b/meta/recipes-devtools/perl/libxml-simple-perl_2.18.bb
index 3a50d7f1d2..f2abf9dff9 100644
--- a/meta/recipes-devtools/perl/libxml-simple-perl_2.18.bb
+++ b/meta/recipes-devtools/perl/libxml-simple-perl_2.18.bb
@@ -14,3 +14,5 @@ S = "${WORKDIR}/XML-Simple-${PV}"
EXTRA_PERLFLAGS = "-I ${STAGING_LIBDIR_NATIVE}/perl-native/perl/${@get_perl_version(d)}"
inherit cpan
+
+BBCLASSEXTEND = "native"