summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/mmc
diff options
context:
space:
mode:
authorChase Maupin <Chase.Maupin@ti.com>2014-03-18 06:56:13 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-26 12:15:11 +0000
commit6ce4010951a291aec72a3e4997cd7c523a22ac87 (patch)
treefa8d3b2c62be27d4ab455581fb69650bfbb351b1 /meta/recipes-devtools/mmc
parentcd06824bda76a9d08a3318e0621e31c0e8c39f74 (diff)
downloadopenembedded-core-6ce4010951a291aec72a3e4997cd7c523a22ac87.tar.gz
mmc-utils: Add user space mmc utilities for eMMC
* The mmc-utils are useful userspace utilities for configuring and working with MMC devices. These are particularly useful when working with eMMC devices to do the initial programming of the device. Signed-off-by: Chase Maupin <Chase.Maupin@ti.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/mmc')
-rw-r--r--meta/recipes-devtools/mmc/mmc-utils_git.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-devtools/mmc/mmc-utils_git.bb b/meta/recipes-devtools/mmc/mmc-utils_git.bb
new file mode 100644
index 0000000000..abde4b1110
--- /dev/null
+++ b/meta/recipes-devtools/mmc/mmc-utils_git.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Userspace tools for MMC/SD devices"
+HOMEPAGE = "http://git.kernel.org/cgit/linux/kernel/git/cjb/mmc-utils.git/"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://mmc.c;beginline=1;endline=17;md5=d7747fc87f1eb22b946ef819969503f0"
+
+BRANCH ?= "master"
+SRCREV = "11f2ceabc4ad3f0dd568e0ce68166e4803e0615b"
+
+PV = "0.1"
+
+SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/cjb/mmc-utils.git;protocol=git;branch=${BRANCH}"
+
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 mmc ${D}${bindir}
+}