summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go/go-binary-native_1.20.9.bb
diff options
context:
space:
mode:
authorJose Quaresma <quaresma.jose@gmail.com>2023-10-09 16:40:37 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-10-12 07:53:16 +0100
commit7962b93a53f928cd618016fa600ccefb2d57c28d (patch)
treedca02a5ad4441c17f6f8e71499b01616ed5a9672 /meta/recipes-devtools/go/go-binary-native_1.20.9.bb
parent25d0870ae045a6f7845ebc905f2d6602a2ce854d (diff)
downloadopenembedded-core-7962b93a53f928cd618016fa600ccefb2d57c28d.tar.gz
go: update 1.20.8 -> 1.20.9
Upgrade to latest 1.20.x release [1]: $ git log --oneline go1.20.8..go1.20.9 68f9a6e2ad (tag: go1.20.9) [release-branch.go1.20] go1.20.9 31d5b604ac [release-branch.go1.20] cmd/compile: use absolute file name in isCgo check 83dce45959 [release-branch.go1.20] cmd/link: suppress -bind_at_load deprecation warning for ld-prime 08c544db98 [release-branch.go1.20] cmd/link: disable DWARF by default in c-shared mode on darwin 071f03a8e5 [release-branch.go1.20] cmd/link: force old Apple linker in plugin mode [1] https://github.com/golang/go/compare/go1.20.8...go1.20.9 Signed-off-by: Jose Quaresma <jose.quaresma@foundries.io> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/go/go-binary-native_1.20.9.bb')
-rw-r--r--meta/recipes-devtools/go/go-binary-native_1.20.9.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-devtools/go/go-binary-native_1.20.9.bb b/meta/recipes-devtools/go/go-binary-native_1.20.9.bb
new file mode 100644
index 0000000000..3fcb923ca0
--- /dev/null
+++ b/meta/recipes-devtools/go/go-binary-native_1.20.9.bb
@@ -0,0 +1,50 @@
+# This recipe is for bootstrapping our go-cross from a prebuilt binary of Go from golang.org.
+
+SUMMARY = "Go programming language compiler (upstream binary for bootstrap)"
+HOMEPAGE = " http://golang.org/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5d4950ecb7b26d2c5e4e7b4e0dd74707"
+
+PROVIDES = "go-native"
+
+# Checksums available at https://go.dev/dl/
+SRC_URI = "https://dl.google.com/go/go${PV}.${BUILD_GOOS}-${BUILD_GOARCH}.tar.gz;name=go_${BUILD_GOTUPLE}"
+SRC_URI[go_linux_amd64.sha256sum] = "8921369701afa749b07232d2c34d514510c32dbfd79c65adb379451b5f0d7216"
+SRC_URI[go_linux_arm64.sha256sum] = "da7fca78f85b90b495382cd74b2d0a1c0b6aaa200e7feb27ae7198352b2317fa"
+SRC_URI[go_linux_ppc64le.sha256sum] = "2db0628914522d9d2dbc7070877131dd9d1f8f74387f2f32314b5cfb5e45ff82"
+
+UPSTREAM_CHECK_URI = "https://golang.org/dl/"
+UPSTREAM_CHECK_REGEX = "go(?P<pver>\d+(\.\d+)+)\.linux"
+
+CVE_PRODUCT = "go"
+
+S = "${WORKDIR}/go"
+
+inherit goarch native
+
+do_compile() {
+ :
+}
+
+make_wrapper() {
+ rm -f ${D}${bindir}/$1
+ cat <<END >${D}${bindir}/$1
+#!/bin/bash
+here=\`dirname \$0\`
+export GOROOT="${GOROOT:-\`readlink -f \$here/../lib/go\`}"
+\$here/../lib/go/bin/$1 "\$@"
+END
+ chmod +x ${D}${bindir}/$1
+}
+
+do_install() {
+ find ${S} -depth -type d -name testdata -exec rm -rf {} +
+
+ install -d ${D}${bindir} ${D}${libdir}/go
+ cp --preserve=mode,timestamps -R ${S}/ ${D}${libdir}/
+
+ for f in ${S}/bin/*
+ do
+ make_wrapper `basename $f`
+ done
+}