summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gdb/gdb_8.0.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-06-06 23:29:30 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-06-12 15:04:07 +0100
commitcaf2f858bf41154c72aba37d58b5a5336e02fbb8 (patch)
tree0b7f5c9d656bc46a22d1273350b6bed4085180a7 /meta/recipes-devtools/gdb/gdb_8.0.bb
parentcde66d5eac8e5c2821ba225dc4be4af4e0581652 (diff)
downloadopenembedded-core-caf2f858bf41154c72aba37d58b5a5336e02fbb8.tar.gz
gdb: Upgrade to 8.0 release
For details on changes see http://lists.gnu.org/archive/html/info-gnu/2017-06/msg00002.html in tcmode-default.inc Pin gdb to 8.0 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/gdb/gdb_8.0.bb')
-rw-r--r--meta/recipes-devtools/gdb/gdb_8.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gdb/gdb_8.0.bb b/meta/recipes-devtools/gdb/gdb_8.0.bb
new file mode 100644
index 0000000000..ea8fef122c
--- /dev/null
+++ b/meta/recipes-devtools/gdb/gdb_8.0.bb
@@ -0,0 +1,27 @@
+require gdb.inc
+require gdb-${PV}.inc
+
+inherit python3-dir
+
+EXTRA_OEMAKE_append_libc-musl = "\
+ gt_cv_func_gnugettext1_libc=yes \
+ gt_cv_func_gnugettext2_libc=yes \
+ gl_cv_func_gettimeofday_clobber=no \
+ "
+
+do_configure_prepend() {
+ if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then
+ cat > ${WORKDIR}/python << EOF
+#!/bin/sh
+case "\$2" in
+ --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}/" ;;
+ --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}${PYTHON_ABI}" ;;
+ --exec-prefix) echo "${exec_prefix}" ;;
+ *) exit 1 ;;
+esac
+exit 0
+EOF
+ chmod +x ${WORKDIR}/python
+ fi
+}
+CFLAGS_append_libc-musl = " -Drpl_gettimeofday=gettimeofday"