summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gcc/gcc_7.3.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-23 17:03:26 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-26 23:24:45 +0000
commita4c1ede6876ad6b84ab2b3bece14bf0afdc9d6b7 (patch)
tree6dc7862e6065db64b254f5daceb673f96db0037c /meta/recipes-devtools/gcc/gcc_7.3.bb
parent222537d8dcf103d8dcce2df7e915594c480ef110 (diff)
downloadopenembedded-core-a4c1ede6876ad6b84ab2b3bece14bf0afdc9d6b7.tar.gz
gcc: Upgrade 7.2 -> 7.3
The static PIE patch was updated by Juro Bystricky <juro.bystricky@intel.com> to work with gcc 7.3. This update from the stable gcc 7 branch includes the retpoline functionality which is useful to assist with recent security issues. Two backported patches were dropped as they're included in 7.3. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/gcc/gcc_7.3.bb')
-rw-r--r--meta/recipes-devtools/gcc/gcc_7.3.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gcc/gcc_7.3.bb b/meta/recipes-devtools/gcc/gcc_7.3.bb
new file mode 100644
index 0000000000..ab208e7026
--- /dev/null
+++ b/meta/recipes-devtools/gcc/gcc_7.3.bb
@@ -0,0 +1,10 @@
+require recipes-devtools/gcc/gcc-${PV}.inc
+require gcc-target.inc
+
+# Building with thumb enabled on armv4t armv5t fails with
+# | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7438:(.text.unlikely+0x2fa): relocation truncated to fit: R_ARM_THM_CALL against symbol `fancy_abort(char const*, int, char const*)' defined in .glue_7 section in linker stubs
+# | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7442:(.text.unlikely+0x318): additional relocation overflows omitted from the output
+ARM_INSTRUCTION_SET_armv4 = "arm"
+ARM_INSTRUCTION_SET_armv5 = "arm"
+
+BBCLASSEXTEND = "nativesdk"