summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/elfutils
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-08-18 17:33:18 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-08-20 08:51:08 +0100
commit41ecc76c7fab8f9805d3271255bcd027d87298bb (patch)
tree0629fb5d4f8c15d795e2fe9f37bf7f27cb9792c9 /meta/recipes-devtools/elfutils
parent5c2b1fb09e786ec392979d21dc7884ca23cd84f0 (diff)
downloadopenembedded-core-41ecc76c7fab8f9805d3271255bcd027d87298bb.tar.gz
elfutils: Fix ptest dependencies
The elfutils ptests require debug symbols for the libc to be available, else we see failures such as those on the autobuilder for the fast ptest image on arm (the dbg symbols are pulled in by other recipes in other images). Also fix various test skips/error messages due to missing gcc/ld and development headers. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/elfutils')
-rw-r--r--meta/recipes-devtools/elfutils/elfutils_0.185.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-devtools/elfutils/elfutils_0.185.bb b/meta/recipes-devtools/elfutils/elfutils_0.185.bb
index 3d103c7c48..9ea4de8e40 100644
--- a/meta/recipes-devtools/elfutils/elfutils_0.185.bb
+++ b/meta/recipes-devtools/elfutils/elfutils_0.185.bb
@@ -50,11 +50,12 @@ PACKAGECONFIG[zstd] = "--with-zstd,--without-zstd,zstd"
PACKAGECONFIG[libdebuginfod] = "--enable-libdebuginfod,--disable-libdebuginfod,curl"
PACKAGECONFIG[debuginfod] = "--enable-debuginfod,--disable-debuginfod,libarchive sqlite3 libmicrohttpd"
-RDEPENDS:${PN}-ptest += "libasm libelf bash make coreutils ${PN}-binutils iproute2-ss bsdtar"
+RDEPENDS:${PN}-ptest += "libasm libelf bash make coreutils ${PN}-binutils iproute2-ss bsdtar gcc-symlinks binutils-symlinks libgcc-dev"
EXTRA_OECONF:append:class-target = " --disable-tests-rpath"
-RDEPENDS:${PN}-ptest:append:libc-glibc = " glibc-utils"
+RDEPENDS:${PN}-ptest:append:libc-glibc = " glibc-utils glibc-dbg glibc-dev"
+INSANE_SKIP:${PN}-ptest = "debug-deps dev-deps"
do_compile_ptest() {
cd ${B}/tests