summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cmake
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-05-03 19:51:02 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-05-05 11:07:21 +0100
commitf038e40328eff37fe5d16310853448ba21e5c9f4 (patch)
tree80b105ca39da9838c2aeef181c7f491f46d5a2f3 /meta/recipes-devtools/cmake
parentdafb93e64ea59a970d1932ce42eaed5b9419dfbb (diff)
downloadopenembedded-core-f038e40328eff37fe5d16310853448ba21e5c9f4.tar.gz
cmake: Upgrade to 3.26.3
License-Update: Copyright year changed from 2022 -> 2023 - Copyright 2000-2022 Kitware, Inc. and Contributors + Copyright 2000-2023 Kitware, Inc. and Contributors Call bootstrap directly without wrapping it with configure since all it does it find the sourcedir Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/cmake')
-rw-r--r--meta/recipes-devtools/cmake/cmake-native_3.26.3.bb (renamed from meta/recipes-devtools/cmake/cmake-native_3.25.2.bb)2
-rw-r--r--meta/recipes-devtools/cmake/cmake.inc4
-rw-r--r--meta/recipes-devtools/cmake/cmake_3.26.3.bb (renamed from meta/recipes-devtools/cmake/cmake_3.25.2.bb)0
3 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-devtools/cmake/cmake-native_3.25.2.bb b/meta/recipes-devtools/cmake/cmake-native_3.26.3.bb
index c150aef5ef..2177aa81a4 100644
--- a/meta/recipes-devtools/cmake/cmake-native_3.25.2.bb
+++ b/meta/recipes-devtools/cmake/cmake-native_3.26.3.bb
@@ -38,7 +38,7 @@ CMAKE_EXTRACONF = "\
"
do_configure () {
- ${S}/configure --verbose --prefix=${prefix} \
+ ${S}/bootstrap --verbose --prefix=${prefix} \
${@oe.utils.parallel_make_argument(d, '--parallel=%d')} \
${@bb.utils.contains('CCACHE', 'ccache ', '--enable-ccache', '', d)} \
-- ${CMAKE_EXTRACONF}
diff --git a/meta/recipes-devtools/cmake/cmake.inc b/meta/recipes-devtools/cmake/cmake.inc
index b7e674c4c4..2b6554690b 100644
--- a/meta/recipes-devtools/cmake/cmake.inc
+++ b/meta/recipes-devtools/cmake/cmake.inc
@@ -10,7 +10,7 @@ HOMEPAGE = "http://www.cmake.org/"
BUGTRACKER = "http://public.kitware.com/Bug/my_view_page.php"
SECTION = "console/utils"
LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://Copyright.txt;md5=09069e0fffe4e5eaf6dde04c3b1932e5 \
+LIC_FILES_CHKSUM = "file://Copyright.txt;md5=9d3d12c5f3b4c1f83650adcc65b59c06 \
file://Source/cmake.h;beginline=1;endline=2;md5=a5f70e1fef8614734eae0d62b4f5891b \
"
@@ -19,7 +19,7 @@ CMAKE_MAJOR_VERSION = "${@'.'.join(d.getVar('PV').split('.')[0:2])}"
SRC_URI = "https://cmake.org/files/v${CMAKE_MAJOR_VERSION}/cmake-${PV}.tar.gz \
"
-SRC_URI[sha256sum] = "c026f22cb931dd532f648f087d587f07a1843c6e66a3dfca4fb0ea21944ed33c"
+SRC_URI[sha256sum] = "bbd8d39217509d163cb544a40d6428ac666ddc83e22905d3e52c925781f0f659"
UPSTREAM_CHECK_REGEX = "cmake-(?P<pver>\d+(\.\d+)+)\.tar"
diff --git a/meta/recipes-devtools/cmake/cmake_3.25.2.bb b/meta/recipes-devtools/cmake/cmake_3.26.3.bb
index bb7ed83e30..bb7ed83e30 100644
--- a/meta/recipes-devtools/cmake/cmake_3.25.2.bb
+++ b/meta/recipes-devtools/cmake/cmake_3.26.3.bb