summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cmake
diff options
context:
space:
mode:
authorTrevor Gamblin <tgamblin@baylibre.com>2024-02-06 12:20:34 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-02-08 17:12:51 +0000
commit64b3832c5c96ee44ccc3da633a065eef33e3e03d (patch)
treec3e0792acc31295ae716c7e6d81d15652bbc8478 /meta/recipes-devtools/cmake
parentb685c955289bf4d7d70bd0f4c1530b2bf13a30a6 (diff)
downloadopenembedded-core-64b3832c5c96ee44ccc3da633a065eef33e3e03d.tar.gz
cmake: upgrade 3.27.7 -> 3.28.3
Changelog: https://cmake.org/cmake/help/latest/release/3.28.html The patch 0001-CMakeLists.txt-disable-USE_NGHTTP2.patch had to be adjusted to apply cleanly on top of the new source version. Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/cmake')
-rw-r--r--meta/recipes-devtools/cmake/cmake-native_3.28.3.bb (renamed from meta/recipes-devtools/cmake/cmake-native_3.27.7.bb)0
-rw-r--r--meta/recipes-devtools/cmake/cmake.inc2
-rw-r--r--meta/recipes-devtools/cmake/cmake/0001-CMakeLists.txt-disable-USE_NGHTTP2.patch14
-rw-r--r--meta/recipes-devtools/cmake/cmake_3.28.3.bb (renamed from meta/recipes-devtools/cmake/cmake_3.27.7.bb)0
4 files changed, 10 insertions, 6 deletions
diff --git a/meta/recipes-devtools/cmake/cmake-native_3.27.7.bb b/meta/recipes-devtools/cmake/cmake-native_3.28.3.bb
index 546d117156..546d117156 100644
--- a/meta/recipes-devtools/cmake/cmake-native_3.27.7.bb
+++ b/meta/recipes-devtools/cmake/cmake-native_3.28.3.bb
diff --git a/meta/recipes-devtools/cmake/cmake.inc b/meta/recipes-devtools/cmake/cmake.inc
index ecb0e487df..ab9f459c05 100644
--- a/meta/recipes-devtools/cmake/cmake.inc
+++ b/meta/recipes-devtools/cmake/cmake.inc
@@ -19,7 +19,7 @@ CMAKE_MAJOR_VERSION = "${@'.'.join(d.getVar('PV').split('.')[0:2])}"
SRC_URI = "https://cmake.org/files/v${CMAKE_MAJOR_VERSION}/cmake-${PV}.tar.gz \
"
-SRC_URI[sha256sum] = "08f71a106036bf051f692760ef9558c0577c42ac39e96ba097e7662bd4158d8e"
+SRC_URI[sha256sum] = "72b7570e5c8593de6ac4ab433b73eab18c5fb328880460c86ce32608141ad5c1"
UPSTREAM_CHECK_REGEX = "cmake-(?P<pver>\d+(\.\d+)+)\.tar"
diff --git a/meta/recipes-devtools/cmake/cmake/0001-CMakeLists.txt-disable-USE_NGHTTP2.patch b/meta/recipes-devtools/cmake/cmake/0001-CMakeLists.txt-disable-USE_NGHTTP2.patch
index d6486cb45f..b2933d88be 100644
--- a/meta/recipes-devtools/cmake/cmake/0001-CMakeLists.txt-disable-USE_NGHTTP2.patch
+++ b/meta/recipes-devtools/cmake/cmake/0001-CMakeLists.txt-disable-USE_NGHTTP2.patch
@@ -1,4 +1,4 @@
-From 3fd6082c52a8140db5995afb59fb391f7d5c19d7 Mon Sep 17 00:00:00 2001
+From d33d8a5e9f3b25a80d47b72b1a8a6624a85563c1 Mon Sep 17 00:00:00 2001
From: Changqing Li <changqing.li@windriver.com>
Date: Wed, 28 Dec 2022 17:51:27 +0800
Subject: [PATCH] CMakeLists.txt: disable USE_NGHTTP2
@@ -9,17 +9,21 @@ dependency, disable nghttp2.
Upstream-Status: Inappropriate [oe specific]
Signed-off-by: Changqing Li <changqing.li@windriver.com>
+
+Adjust the patch to apply on top of v3.28.3.
+
+Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
---
Utilities/cmcurl/CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Utilities/cmcurl/CMakeLists.txt b/Utilities/cmcurl/CMakeLists.txt
-index f842270b..17b1ce19 100644
+index 9387247366..d3de01f4e8 100644
--- a/Utilities/cmcurl/CMakeLists.txt
+++ b/Utilities/cmcurl/CMakeLists.txt
-@@ -68,7 +68,7 @@ set(ENABLE_UNIX_SOCKETS OFF CACHE INTERNAL "No curl Unix domain sockets support"
- set(HTTP_ONLY OFF CACHE INTERNAL "Curl is not http-only")
+@@ -88,7 +88,7 @@ set(HTTP_ONLY OFF CACHE INTERNAL "Curl is not http-only")
set(PICKY_COMPILER OFF CACHE INTERNAL "Enable picky compiler options")
+ set(SHARE_LIB_OBJECT OFF)
set(USE_LIBIDN2 ON)
-set(USE_NGHTTP2 ON)
+set(USE_NGHTTP2 OFF)
@@ -27,5 +31,5 @@ index f842270b..17b1ce19 100644
set(USE_QUICHE OFF)
set(USE_WIN32_IDN OFF)
--
-2.25.1
+2.43.0
diff --git a/meta/recipes-devtools/cmake/cmake_3.27.7.bb b/meta/recipes-devtools/cmake/cmake_3.28.3.bb
index 6a9a3266df..6a9a3266df 100644
--- a/meta/recipes-devtools/cmake/cmake_3.27.7.bb
+++ b/meta/recipes-devtools/cmake/cmake_3.28.3.bb