summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/ccache
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-08-23 11:01:51 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-09-02 15:54:45 +0100
commita76700a47c227e76551d2f2c86db5841ad7f6e8f (patch)
tree83bb86e36056fd504a808f8d38128ced88e1373d /meta/recipes-devtools/ccache
parent0469854032ad8ce3f690e84520619d9819263bdc (diff)
downloadopenembedded-core-a76700a47c227e76551d2f2c86db5841ad7f6e8f.tar.gz
ccache: Upgrade to 4.6.2
Fix build with musl Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/ccache')
-rw-r--r--meta/recipes-devtools/ccache/ccache_4.6.2.bb (renamed from meta/recipes-devtools/ccache/ccache_4.6.1.bb)3
-rw-r--r--meta/recipes-devtools/ccache/files/0001-Include-time.h-for-time_t.patch12
-rw-r--r--meta/recipes-devtools/ccache/files/0001-xxhash.h-Fix-build-with-gcc-12.patch6
-rw-r--r--meta/recipes-devtools/ccache/files/0002-config-Include-sys-types.h-for-mode_t-defintion.patch25
4 files changed, 34 insertions, 12 deletions
diff --git a/meta/recipes-devtools/ccache/ccache_4.6.1.bb b/meta/recipes-devtools/ccache/ccache_4.6.2.bb
index 716aec0584..dbac02243c 100644
--- a/meta/recipes-devtools/ccache/ccache_4.6.1.bb
+++ b/meta/recipes-devtools/ccache/ccache_4.6.2.bb
@@ -14,8 +14,9 @@ DEPENDS = "zstd"
SRC_URI = "https://github.com/ccache/ccache/releases/download/v${PV}/${BP}.tar.gz \
file://0001-xxhash.h-Fix-build-with-gcc-12.patch \
file://0001-Include-time.h-for-time_t.patch \
+ file://0002-config-Include-sys-types.h-for-mode_t-defintion.patch \
"
-SRC_URI[sha256sum] = "59b28a57c3a45e48d6049001999c9f94cd4d3e9b0196994bed9a6a7437ffa3bc"
+SRC_URI[sha256sum] = "6a746a9bed01585388b68e2d58af2e77741fc8d66bc360b5a0b4c41fc284dafe"
UPSTREAM_CHECK_URI = "https://github.com/ccache/ccache/releases/"
diff --git a/meta/recipes-devtools/ccache/files/0001-Include-time.h-for-time_t.patch b/meta/recipes-devtools/ccache/files/0001-Include-time.h-for-time_t.patch
index 6c1d3cf4f9..d752eb0651 100644
--- a/meta/recipes-devtools/ccache/files/0001-Include-time.h-for-time_t.patch
+++ b/meta/recipes-devtools/ccache/files/0001-Include-time.h-for-time_t.patch
@@ -1,4 +1,4 @@
-From 3d3364221c235c733436abaeeea9b5e6813b06ae Mon Sep 17 00:00:00 2001
+From 590c656838a9b3769a7a855fb1891bfa8d8878ad Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Tue, 23 Aug 2022 10:27:21 -0700
Subject: [PATCH] Include time.h for time_t
@@ -10,22 +10,20 @@ src/core/Statistics.hpp:41:37: error: 'time_t' has not been declared
Upstream-Status: Submitted [https://github.com/ccache/ccache/pull/1145]
Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
---
src/core/Statistics.hpp | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/core/Statistics.hpp b/src/core/Statistics.hpp
-index 3e9ed816..0017f209 100644
+index 54f32e9..eb80e1c 100644
--- a/src/core/Statistics.hpp
+++ b/src/core/Statistics.hpp
-@@ -20,6 +20,7 @@
-
+@@ -21,6 +21,7 @@
#include <core/StatisticsCounters.hpp>
+ #include <cstdint>
+#include <ctime>
#include <string>
#include <unordered_map>
#include <vector>
---
-2.37.2
-
diff --git a/meta/recipes-devtools/ccache/files/0001-xxhash.h-Fix-build-with-gcc-12.patch b/meta/recipes-devtools/ccache/files/0001-xxhash.h-Fix-build-with-gcc-12.patch
index aab943459d..67c74a1e8e 100644
--- a/meta/recipes-devtools/ccache/files/0001-xxhash.h-Fix-build-with-gcc-12.patch
+++ b/meta/recipes-devtools/ccache/files/0001-xxhash.h-Fix-build-with-gcc-12.patch
@@ -1,4 +1,4 @@
-From cfde5ba7d10ae1e9d0c259dd1e7027e9bad8f83c Mon Sep 17 00:00:00 2001
+From 550834a3ec2e05e379be63b084e7fa06a1723f84 Mon Sep 17 00:00:00 2001
From: Mingli Yu <mingli.yu@windriver.com>
Date: Mon, 6 Jun 2022 17:53:20 +0800
Subject: [PATCH] xxhash.h: Fix build with gcc-12
@@ -17,6 +17,7 @@ Remove inline attribute to fix below build failure:
Upstream-Status: Submitted [https://github.com/Cyan4973/xxHash/pull/720]
Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
+
---
src/third_party/xxhash.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
@@ -34,6 +35,3 @@ index 08ab794..c754e99 100644
# define XXH_NO_INLINE static __attribute__((noinline))
#elif defined(_MSC_VER) /* Visual Studio */
# define XXH_FORCE_INLINE static __forceinline
---
-2.25.1
-
diff --git a/meta/recipes-devtools/ccache/files/0002-config-Include-sys-types.h-for-mode_t-defintion.patch b/meta/recipes-devtools/ccache/files/0002-config-Include-sys-types.h-for-mode_t-defintion.patch
new file mode 100644
index 0000000000..0fd77602df
--- /dev/null
+++ b/meta/recipes-devtools/ccache/files/0002-config-Include-sys-types.h-for-mode_t-defintion.patch
@@ -0,0 +1,25 @@
+From f98b390a2d323f7f92fb0492b0943d201afe5b8f Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Tue, 23 Aug 2022 10:40:53 -0700
+Subject: [PATCH] config: Include sys/types.h for mode_t defintion
+
+Upstream-Status: Submitted [https://github.com/ccache/ccache/pull/1145]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+---
+ src/Config.hpp | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/Config.hpp b/src/Config.hpp
+index a9e08ec..9e7af40 100644
+--- a/src/Config.hpp
++++ b/src/Config.hpp
+@@ -25,6 +25,8 @@
+
+ #include "third_party/nonstd/optional.hpp"
+
++#include <sys/types.h>
++
+ #include <cstdint>
+ #include <functional>
+ #include <limits>