summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/ccache
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-01-02 15:20:49 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-01-07 12:24:54 +0000
commita237c43adc717ea92e1353ee93c29b47a52ad81a (patch)
tree903bb7bfc32651add81453d4bd74176d8c70916e /meta/recipes-devtools/ccache
parent51b5e79cd37de982492991e56362cf1f0ef2ab8e (diff)
downloadopenembedded-core-a237c43adc717ea92e1353ee93c29b47a52ad81a.tar.gz
ccache: upgrade 4.8.3 -> 4.9
License-Update: =============== Upgrade to fmt 10.1.1 Upgrade to cpp-httplib 0.14.3 Upgrade to BLAKE3 1.5.0 Changelog: https://ccache.dev/releasenotes.html#_ccache_4_9 0001-xxhash.h-Fix-build-with-gcc-12.patch refreshed for 4.9 Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/ccache')
-rw-r--r--meta/recipes-devtools/ccache/ccache_4.9.bb (renamed from meta/recipes-devtools/ccache/ccache_4.8.3.bb)4
-rw-r--r--meta/recipes-devtools/ccache/files/0001-xxhash.h-Fix-build-with-gcc-12.patch6
2 files changed, 5 insertions, 5 deletions
diff --git a/meta/recipes-devtools/ccache/ccache_4.8.3.bb b/meta/recipes-devtools/ccache/ccache_4.9.bb
index 03372aa685..8550470e3f 100644
--- a/meta/recipes-devtools/ccache/ccache_4.8.3.bb
+++ b/meta/recipes-devtools/ccache/ccache_4.9.bb
@@ -7,14 +7,14 @@ HOMEPAGE = "http://ccache.samba.org"
SECTION = "devel"
LICENSE = "GPL-3.0-or-later"
-LIC_FILES_CHKSUM = "file://LICENSE.adoc;md5=6a6fe0ae4e57592b187ab72fa6d420ec"
+LIC_FILES_CHKSUM = "file://LICENSE.adoc;md5=11b0b581dd56bbac4f5de214d47927ca"
DEPENDS = "zstd"
SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/${BP}.tar.gz \
file://0001-xxhash.h-Fix-build-with-gcc-12.patch \
"
-SRC_URI[sha256sum] = "d59dd569ad2bbc826c0bc335c8ebd73e78ed0f2f40ba6b30069347e63585d9ef"
+SRC_URI[sha256sum] = "866b2223d59333640f0e7a003cbb85b32d9ca3c9445bd9e3cf142942e69dd3ec"
inherit cmake github-releases
diff --git a/meta/recipes-devtools/ccache/files/0001-xxhash.h-Fix-build-with-gcc-12.patch b/meta/recipes-devtools/ccache/files/0001-xxhash.h-Fix-build-with-gcc-12.patch
index 67c74a1e8e..e65b830257 100644
--- a/meta/recipes-devtools/ccache/files/0001-xxhash.h-Fix-build-with-gcc-12.patch
+++ b/meta/recipes-devtools/ccache/files/0001-xxhash.h-Fix-build-with-gcc-12.patch
@@ -1,4 +1,4 @@
-From 550834a3ec2e05e379be63b084e7fa06a1723f84 Mon Sep 17 00:00:00 2001
+From d17fdacf4892a15fafb56b0890ece05b485e89fb Mon Sep 17 00:00:00 2001
From: Mingli Yu <mingli.yu@windriver.com>
Date: Mon, 6 Jun 2022 17:53:20 +0800
Subject: [PATCH] xxhash.h: Fix build with gcc-12
@@ -23,10 +23,10 @@ Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/third_party/xxhash.h b/src/third_party/xxhash.h
-index 08ab794..c754e99 100644
+index a18e8c7..1b72307 100644
--- a/src/third_party/xxhash.h
+++ b/src/third_party/xxhash.h
-@@ -1501,7 +1501,7 @@ static void* XXH_memcpy(void* dest, const void* src, size_t size)
+@@ -2107,7 +2107,7 @@ static void* XXH_memcpy(void* dest, const void* src, size_t size)
# define XXH_NO_INLINE static
/* enable inlining hints */
#elif defined(__GNUC__) || defined(__clang__)