summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorChris Laplante <chris.laplante@agilent.com>2020-09-14 11:33:18 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-09-14 22:44:49 +0100
commitcbc717350b21fb417fa6f83621022ac633a26124 (patch)
tree5da8d05c560ac184517e364dcd7e4caf07a83b4a /meta/recipes-core
parent0cccb2ae6508c0b3d4a5362e61b24ee314c2fb02 (diff)
downloadopenembedded-core-cbc717350b21fb417fa6f83621022ac633a26124.tar.gz
cve-update-db-native: be less magical about checking whether the cve-check class is enabled
Signed-off-by: Chris Laplante <chris.laplante@agilent.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/meta/cve-update-db-native.bb3
1 files changed, 1 insertions, 2 deletions
diff --git a/meta/recipes-core/meta/cve-update-db-native.bb b/meta/recipes-core/meta/cve-update-db-native.bb
index e4e2451bfd..c2f713312f 100644
--- a/meta/recipes-core/meta/cve-update-db-native.bb
+++ b/meta/recipes-core/meta/cve-update-db-native.bb
@@ -13,8 +13,7 @@ deltask do_install
deltask do_populate_sysroot
python () {
- cve_check_db_file = d.getVar("CVE_CHECK_DB_FILE")
- if not cve_check_db_file:
+ if not bb.data.inherits_class("cve-check", d):
raise bb.parse.SkipRecipe("Skip recipe when cve-check class is not loaded.")
if os.path.exists("%s-journal" % cve_check_db_file ):