summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/tinylogin/tinylogin_1.4.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2013-04-05 10:09:31 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-04-05 18:21:12 +0100
commit03034e0f5dff426ee7adaa2364082dd47c23260a (patch)
tree3f019599ae06da7cd4ec0e936c188070eccf93e8 /meta/recipes-core/tinylogin/tinylogin_1.4.bb
parenta51041db57666c60f39c4effa4aceb53cae815dc (diff)
downloadopenembedded-core-03034e0f5dff426ee7adaa2364082dd47c23260a.tar.gz
tinylogin: fix segfault from crypt()
In glibc 2.17, crypt() now expects 2 valid chars for the seed or it will error out and return a NULL. The tinylogin code took the result from crypt directly into a strcmp() which caused a segfault Tinylogin has been deperacted, busybox now has login support, I will investigate using busybox login support for 1.5. [YOCTO #4097] Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/tinylogin/tinylogin_1.4.bb')
-rw-r--r--meta/recipes-core/tinylogin/tinylogin_1.4.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-core/tinylogin/tinylogin_1.4.bb b/meta/recipes-core/tinylogin/tinylogin_1.4.bb
index aaed92aad2..6e08011004 100644
--- a/meta/recipes-core/tinylogin/tinylogin_1.4.bb
+++ b/meta/recipes-core/tinylogin/tinylogin_1.4.bb
@@ -18,7 +18,9 @@ SRC_URI = "http://www.angstrom-distribution.org/unstable/sources/tinylogin-${PV}
file://remove-index.patch \
file://use_O2_option.patch \
file://passwd_rotate_check.patch \
- file://avoid_static.patch"
+ file://avoid_static.patch \
+ file://glibc_crypt_fix.patch \
+ "
SRC_URI[md5sum] = "44da0ff2b727455669890b24305e351d"
SRC_URI[sha256sum] = "5e542e4b7825305a3678bf73136c392feb0d44b8bbf926e8eda5453eea7ddd6b"