summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/package-index.bb
diff options
context:
space:
mode:
authorSaul Wold <Saul.Wold@intel.com>2010-11-22 13:57:13 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2010-11-22 13:57:13 +0000
commitcfe12efb5ec9586dab6961f141d52b103bd8b1d1 (patch)
tree7108e22aa7ddf6cfc2f1b6c6b73a811187706ecb /meta/recipes-core/meta/package-index.bb
parent762fd6b7b3b22d7a8cb80ef9e9ba62e7ef21af3e (diff)
downloadopenembedded-core-cfe12efb5ec9586dab6961f141d52b103bd8b1d1.tar.gz
Meta: Recipe Reogranization
This is the next stage of recipe reorganization, in this stage many recipes where moved to a new meta-demoapps layer since this is more appropriate for demo usage then the core. Additional some recipes were moved to meta-extras to indicate they may be depercated at a future time. A number of recipes were modified since dependencies need to be corrected. Signed-off-by: Saul Wold <Saul.Wold@intel.com>
Diffstat (limited to 'meta/recipes-core/meta/package-index.bb')
-rw-r--r--meta/recipes-core/meta/package-index.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-core/meta/package-index.bb b/meta/recipes-core/meta/package-index.bb
new file mode 100644
index 0000000000..21822fe9da
--- /dev/null
+++ b/meta/recipes-core/meta/package-index.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Rebuild the package index"
+LICENSE = "MIT"
+
+INHIBIT_DEFAULT_DEPS = "1"
+ALLOW_EMPTY = "1"
+PACKAGES = ""
+
+do_fetch() {
+}
+do_unpack() {
+}
+do_patch() {
+}
+do_configure() {
+}
+do_compile() {
+}
+do_install() {
+}
+
+do_build[nostamp] = "1"
+do_build[dirs] = "${DEPLOY_DIR_IPK}"
+do_build() {
+ set -ex
+ package_update_index_ipk
+ set +ex
+}
+
+EXCLUDE_FROM_WORLD = "1"