summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/libxcrypt/libxcrypt_4.4.6.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-05-20 16:11:03 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-22 07:24:38 +0100
commit12efd701b9875bb955dca038ab67b7fec8fb21f4 (patch)
tree64a30007032af9082670c0d6131002da303fcd3c /meta/recipes-core/libxcrypt/libxcrypt_4.4.6.bb
parent7c0d51db40a6130ee306381bc18a4a426810a66b (diff)
downloadopenembedded-core-12efd701b9875bb955dca038ab67b7fec8fb21f4.tar.gz
libxcrypt: upgrade 4.4.4 -> 4.4.6
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/libxcrypt/libxcrypt_4.4.6.bb')
-rw-r--r--meta/recipes-core/libxcrypt/libxcrypt_4.4.6.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-core/libxcrypt/libxcrypt_4.4.6.bb b/meta/recipes-core/libxcrypt/libxcrypt_4.4.6.bb
new file mode 100644
index 0000000000..637c0e6ffb
--- /dev/null
+++ b/meta/recipes-core/libxcrypt/libxcrypt_4.4.6.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Extended cryptographic library (from glibc)"
+DESCRIPTION = "Forked code from glibc libary to extract only crypto part."
+HOMEPAGE = "https://github.com/besser82/libxcrypt"
+SECTION = "libs"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM ?= "file://LICENSING;md5=be275bc7f91642efe7709a8ae7a1433b \
+ file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
+"
+
+inherit autotools pkgconfig
+
+PV = "4.4.6"
+
+SRC_URI = "git://github.com/besser82/libxcrypt.git;branch=${SRCBRANCH}"
+SRCREV = "398943774c5ff38baf1bc5ee088855fd8983bb05"
+SRCBRANCH ?= "develop"
+
+PROVIDES = "virtual/crypt"
+
+FILES_${PN} = "${libdir}/libcrypt*.so.* \
+ ${libdir}/libcrypt-*.so \
+ ${libdir}/libowcrypt*.so.* \
+ ${libdir}/libowcrypt-*.so \
+"
+
+S = "${WORKDIR}/git"
+
+BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
+TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir} -Wno-error=missing-attributes"
+CPPFLAGS_append_class-nativesdk = " -Wno-error=missing-attributes"
+
+BBCLASSEXTEND = "nativesdk"