summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glib-2.0
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2024-01-10 13:07:22 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-01-12 11:51:18 +0000
commitf91694fa8f5c2c3e6f4946300f040677cb0828fd (patch)
treec9c23f10ed28b2435624dd692108940264dd1071 /meta/recipes-core/glib-2.0
parent2f88e7d331390c6aaecc4522253e24791aec299e (diff)
downloadopenembedded-core-f91694fa8f5c2c3e6f4946300f040677cb0828fd.tar.gz
glib-2.0: no need to depend on target gtk-doc
The meson.build looks for a target gtk-doc, but it should be looking for the native package. Fixing this means we can drop the need for a target gtk-doc package. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glib-2.0')
-rw-r--r--meta/recipes-core/glib-2.0/glib-2.0/native-gtkdoc.patch21
-rw-r--r--meta/recipes-core/glib-2.0/glib-2.0_2.78.3.bb1
-rw-r--r--meta/recipes-core/glib-2.0/glib.inc2
3 files changed, 22 insertions, 2 deletions
diff --git a/meta/recipes-core/glib-2.0/glib-2.0/native-gtkdoc.patch b/meta/recipes-core/glib-2.0/glib-2.0/native-gtkdoc.patch
new file mode 100644
index 0000000000..f56c2b8564
--- /dev/null
+++ b/meta/recipes-core/glib-2.0/glib-2.0/native-gtkdoc.patch
@@ -0,0 +1,21 @@
+docs/reference: depend on a native gtk-doc
+
+In a cross-compiled environment we don't need a target gtk-doc, but a
+native gtk-doc.
+
+Upstream-Status: Backport [f3ff370d1b24f8afb51cd4e865593d5b678188a9]
+Signed-off-by: Ross Burton <ross.burton@arm.com>
+
+diff --git a/docs/reference/meson.build b/docs/reference/meson.build
+index c417ffecb..67c1dda56 100644
+--- a/docs/reference/meson.build
++++ b/docs/reference/meson.build
+@@ -42,7 +42,7 @@ ignore_decorators = '|'.join(ignore_decorators)
+ if get_option('gtk_doc')
+ # Check we have the minimum gtk-doc version required. Older versions won't
+ # generate correct documentation.
+- dependency('gtk-doc', version : '>=1.32.1',
++ dependency('gtk-doc', version : '>=1.32.1', native: true,
+ fallback : ['gtk-doc', 'dummy_dep'],
+ default_options : ['tests=false'])
+
diff --git a/meta/recipes-core/glib-2.0/glib-2.0_2.78.3.bb b/meta/recipes-core/glib-2.0/glib-2.0_2.78.3.bb
index 13d4b38e22..2729b2a596 100644
--- a/meta/recipes-core/glib-2.0/glib-2.0_2.78.3.bb
+++ b/meta/recipes-core/glib-2.0/glib-2.0_2.78.3.bb
@@ -14,6 +14,7 @@ SRC_URI = "${GNOME_MIRROR}/glib/${SHRT_VER}/glib-${PV}.tar.xz \
file://0001-Do-not-write-bindir-into-pkg-config-files.patch \
file://0001-meson-Run-atomics-test-on-clang-as-well.patch \
file://0001-gio-tests-resources.c-comment-out-a-build-host-only-.patch \
+ file://native-gtkdoc.patch \
"
SRC_URI:append:class-native = " file://relocate-modules.patch \
file://0001-meson.build-do-not-enable-pidfd-features-on-native-g.patch \
diff --git a/meta/recipes-core/glib-2.0/glib.inc b/meta/recipes-core/glib-2.0/glib.inc
index eb292c51d4..ae6fc51992 100644
--- a/meta/recipes-core/glib-2.0/glib.inc
+++ b/meta/recipes-core/glib-2.0/glib.inc
@@ -30,8 +30,6 @@ LEAD_SONAME = "libglib-2.0.*"
inherit meson gettext gtk-doc pkgconfig ptest-gnome upstream-version-is-even bash-completion gio-module-cache manpages
-DEPENDS:append:class-target = "${@' gtk-doc' if d.getVar('GTKDOC_ENABLED') == 'True' else ''}"
-
GTKDOC_MESON_OPTION = "gtk_doc"
S = "${WORKDIR}/glib-${PV}"