summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/busybox
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2023-10-10 13:54:57 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-10-11 09:42:01 +0100
commit71202782a06ed1f0a17e00072b74b21195f2f5f9 (patch)
treea1370e9fe8cad87e28f4ea43553763f506c8dd37 /meta/recipes-core/busybox
parent8a1060952f8b6956acf747f3853401ac8a981fc3 (diff)
downloadopenembedded-core-71202782a06ed1f0a17e00072b74b21195f2f5f9.tar.gz
busybox-inittab: fix console handling
A testing failure meant that the inittab changes made in 6c65544 didn't actually work. A copy-paste problems meant that start_getty was being invoked instead of getty, but start_getty is sysvinit-inittab-specific. Revert this inittab to calling getty directly. Remove the terminal type, this wasn't specified in the original inittab. Busybox's init has non-standard behaviour for the inittab's ID field. With SysV this is a four-character identifier and nothing more, but with busybox init this is the controlling terminal (minus /dev). If the terminal doesn't exist then busybox doesn't gracefully handle the failure but instead repeatedly fails to spawn. As getty will immediately issue a setsid() this isn't needed for getty entries, so the ID can be empty and ttyrun does the terminal detection. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/busybox')
-rw-r--r--meta/recipes-core/busybox/busybox-inittab_1.36.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/busybox/busybox-inittab_1.36.1.bb b/meta/recipes-core/busybox/busybox-inittab_1.36.1.bb
index 462c9bb9c5..8ee88b6aef 100644
--- a/meta/recipes-core/busybox/busybox-inittab_1.36.1.bb
+++ b/meta/recipes-core/busybox/busybox-inittab_1.36.1.bb
@@ -23,7 +23,7 @@ do_install() {
device=$(echo $s | cut -d\; -f 2)
label=$(echo $device | sed -e 's/tty//' | tail --bytes=5)
- echo "$label::respawn:${sbindir}/ttyrun $device ${base_bindir}/start_getty $speed $device vt102" >> ${D}${sysconfdir}/inittab
+ echo "::respawn:${sbindir}/ttyrun $device ${base_sbindir}/getty $speed $device" >> ${D}${sysconfdir}/inittab
done
if [ "${USE_VT}" = "1" ]; then