summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/base-files
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2019-04-17 10:01:25 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-04-23 23:30:10 +0100
commitf17bcc46341db5ee91bb26389ccaebc68c49b97e (patch)
treec9242e9425508e7cf865baafe93022a581137db3 /meta/recipes-core/base-files
parentba89fea0e443e1492000b7114f32edf15819a151 (diff)
downloadopenembedded-core-f17bcc46341db5ee91bb26389ccaebc68c49b97e.tar.gz
base-files: move hostname operations out of issue file settings
The function do_install_basefilesissue is meant to deal with /etc/issue* files and the following setting could actually be overridden. BASEFILESISSUEINSTALL ?= "do_install_basefilesissue" So move the hostname operations out of this function. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/base-files')
-rw-r--r--meta/recipes-core/base-files/base-files_3.0.14.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta/recipes-core/base-files/base-files_3.0.14.bb b/meta/recipes-core/base-files/base-files_3.0.14.bb
index a1639db830..4b4027f18d 100644
--- a/meta/recipes-core/base-files/base-files_3.0.14.bb
+++ b/meta/recipes-core/base-files/base-files_3.0.14.bb
@@ -134,15 +134,16 @@ do_install () {
install -m 0644 ${WORKDIR}/motd ${D}${sysconfdir}/motd
ln -sf /proc/mounts ${D}${sysconfdir}/mtab
-}
-DISTRO_VERSION[vardepsexclude] += "DATE"
-do_install_basefilesissue () {
+ # deal with hostname
if [ "${hostname}" ]; then
echo ${hostname} > ${D}${sysconfdir}/hostname
echo "127.0.1.1 ${hostname}" >> ${D}${sysconfdir}/hosts
fi
+}
+DISTRO_VERSION[vardepsexclude] += "DATE"
+do_install_basefilesissue () {
install -m 644 ${WORKDIR}/issue* ${D}${sysconfdir}
if [ -n "${DISTRO_NAME}" ]; then
printf "${DISTRO_NAME} " >> ${D}${sysconfdir}/issue