summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity
diff options
context:
space:
mode:
authorAdrian Bunk <bunk@stusta.de>2019-05-17 10:56:14 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-22 07:24:37 +0100
commit3683f524dc60325b3f3b1bc3a32e70a41064ae03 (patch)
tree7f1e2f7be52e3374432e98589c067a35443be1c5 /meta/recipes-connectivity
parent066fa83eeaaa34e5b901dc4b82ad607d0fa78f0b (diff)
downloadopenembedded-core-3683f524dc60325b3f3b1bc3a32e70a41064ae03.tar.gz
ofono: Use external ell instead of an internal copy
Signed-off-by: Adrian Bunk <bunk@stusta.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity')
-rw-r--r--meta/recipes-connectivity/ofono/ofono.inc4
-rw-r--r--meta/recipes-connectivity/ofono/ofono/0001-main-Quiet-ld-errors-with-external-ell.patch36
-rw-r--r--meta/recipes-connectivity/ofono/ofono_1.29.bb1
3 files changed, 39 insertions, 2 deletions
diff --git a/meta/recipes-connectivity/ofono/ofono.inc b/meta/recipes-connectivity/ofono/ofono.inc
index 0472414b19..e1185c6e6b 100644
--- a/meta/recipes-connectivity/ofono/ofono.inc
+++ b/meta/recipes-connectivity/ofono/ofono.inc
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
inherit autotools pkgconfig update-rc.d systemd bluetooth gobject-introspection-data
-DEPENDS = "dbus glib-2.0 udev mobile-broadband-provider-info"
+DEPENDS = "dbus glib-2.0 udev mobile-broadband-provider-info ell"
INITSCRIPT_NAME = "ofono"
INITSCRIPT_PARAMS = "defaults 22"
@@ -19,7 +19,7 @@ PACKAGECONFIG ??= "\
PACKAGECONFIG[systemd] = "--with-systemdunitdir=${systemd_unitdir}/system/,--with-systemdunitdir="
PACKAGECONFIG[bluez] = "--enable-bluetooth, --disable-bluetooth, ${BLUEZ}"
-EXTRA_OECONF += "--enable-test"
+EXTRA_OECONF += "--enable-test --enable-external-ell"
SYSTEMD_SERVICE_${PN} = "ofono.service"
diff --git a/meta/recipes-connectivity/ofono/ofono/0001-main-Quiet-ld-errors-with-external-ell.patch b/meta/recipes-connectivity/ofono/ofono/0001-main-Quiet-ld-errors-with-external-ell.patch
new file mode 100644
index 0000000000..f9858e7f20
--- /dev/null
+++ b/meta/recipes-connectivity/ofono/ofono/0001-main-Quiet-ld-errors-with-external-ell.patch
@@ -0,0 +1,36 @@
+From 48e31f9fc3cf3c486c3d27a67b2687f6df0c5c71 Mon Sep 17 00:00:00 2001
+From: Denis Kenzior <denkenz@gmail.com>
+Date: Thu, 16 May 2019 15:10:53 -0500
+Subject: main: Quiet ld errors with external ell
+
+When oFono is built with --enable-external-ell, the compiler for some
+reason does not generate a debug section on some systems. This is due
+to the fact that l_debug is never called. However, ell also does not
+call l_debug, yet when built-in ell is used, the section is created by
+the compiler.
+
+For now work around this by adding a no-op l_debug() call in main.c.
+The real fix is to migrate all of the oFono logging functionality to use
+ell instead.
+
+Upstream-Status: Backport
+Signed-off-by: Adrian Bunk <bunk@stusta.de>
+---
+ src/main.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/main.c b/src/main.c
+index 8623a060..4529cde1 100644
+--- a/src/main.c
++++ b/src/main.c
+@@ -236,6 +236,7 @@ int main(int argc, char **argv)
+ event_loop = g_main_loop_new(NULL, FALSE);
+
+ l_log_set_stderr();
++ l_debug("");
+ l_debug_enable("*");
+ l_main_init();
+
+--
+2.20.1
+
diff --git a/meta/recipes-connectivity/ofono/ofono_1.29.bb b/meta/recipes-connectivity/ofono/ofono_1.29.bb
index a22b99a728..a5fa81de2f 100644
--- a/meta/recipes-connectivity/ofono/ofono_1.29.bb
+++ b/meta/recipes-connectivity/ofono/ofono_1.29.bb
@@ -5,6 +5,7 @@ SRC_URI = "\
file://ofono \
file://0001-build-Fix-a-race-condition.patch \
file://0001-build-Add-check-for-explicit_bzero-support.patch \
+ file://0001-main-Quiet-ld-errors-with-external-ell.patch \
"
SRC_URI[md5sum] = "4fa0372630ff03f223452e4d05efa8f8"
SRC_URI[sha256sum] = "67f0f8e5740dea5b46309e40667d1e560be39c90ef08dd01ff9e9ce8e61f0679"