summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssl
diff options
context:
space:
mode:
authorJose Quaresma <quaresma.jose@gmail.com>2023-07-06 11:04:55 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-07-14 17:31:02 +0100
commit337ac1159644678508990927923ef8af30f34cd7 (patch)
tree73509da7fbe523138f192d2acd0aa164ca52760a /meta/recipes-connectivity/openssl
parent9bba4570f0ea626ee4f991bac00da0441fc54a75 (diff)
downloadopenembedded-core-337ac1159644678508990927923ef8af30f34cd7.tar.gz
openssl: add PERLEXTERNAL path to test its existence
When upstream change is better to fail or removing the PERL5LIB if they are not need anymore. Signed-off-by: Jose Quaresma <jose.quaresma@foundries.io> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/openssl')
-rw-r--r--meta/recipes-connectivity/openssl/openssl_3.1.1.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_3.1.1.bb b/meta/recipes-connectivity/openssl/openssl_3.1.1.bb
index f5f3f32a97..b849f9ca79 100644
--- a/meta/recipes-connectivity/openssl/openssl_3.1.1.bb
+++ b/meta/recipes-connectivity/openssl/openssl_3.1.1.bb
@@ -137,7 +137,9 @@ do_configure () {
fi
# WARNING: do not set compiler/linker flags (-I/-D etc.) in EXTRA_OECONF, as they will fully replace the
# environment variables set by bitbake. Adjust the environment variables instead.
- HASHBANGPERL="/usr/bin/env perl" PERL=perl PERL5LIB="${S}/external/perl/Text-Template-1.46/lib/" \
+ PERLEXTERNAL="${S}/external/perl/Text-Template-1.46/lib"
+ test -d "$PERLEXTERNAL" || bberror "PERLEXTERNAL '$PERLEXTERNAL' not found!"
+ HASHBANGPERL="/usr/bin/env perl" PERL=perl PERL5LIB="$PERLEXTERNAL" \
perl ${S}/Configure ${EXTRA_OECONF} ${PACKAGECONFIG_CONFARGS} ${DEPRECATED_CRYPTO_FLAGS} --prefix=$useprefix --openssldir=${libdir}/ssl-3 --libdir=${libdir} $target
perl ${B}/configdata.pm --dump
}