summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/iw/iw_4.9.bb
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2016-11-21 14:22:50 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-30 15:47:11 +0000
commit9a04243d307a5bf86a127cf504bec78ee963671c (patch)
tree7c317c445094122392816e0922313b6d8160cbb6 /meta/recipes-connectivity/iw/iw_4.9.bb
parent655818274a1fea53b8abe133e1afdc0eac3cfbb7 (diff)
downloadopenembedded-core-9a04243d307a5bf86a127cf504bec78ee963671c.tar.gz
iw: upgrade to 4.9
Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-connectivity/iw/iw_4.9.bb')
-rw-r--r--meta/recipes-connectivity/iw/iw_4.9.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/iw/iw_4.9.bb b/meta/recipes-connectivity/iw/iw_4.9.bb
new file mode 100644
index 0000000000..6daeb07b70
--- /dev/null
+++ b/meta/recipes-connectivity/iw/iw_4.9.bb
@@ -0,0 +1,33 @@
+SUMMARY = "nl80211 based CLI configuration utility for wireless devices"
+DESCRIPTION = "iw is a new nl80211 based CLI configuration utility for \
+wireless devices. It supports almost all new drivers that have been added \
+to the kernel recently. "
+HOMEPAGE = "http://wireless.kernel.org/en/users/Documentation/iw"
+SECTION = "base"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=878618a5c4af25e9b93ef0be1a93f774"
+
+DEPENDS = "libnl"
+
+SRC_URI = "http://www.kernel.org/pub/software/network/iw/${BP}.tar.gz \
+ file://0001-iw-version.sh-don-t-use-git-describe-for-versioning.patch \
+ file://separate-objdir.patch \
+"
+
+SRC_URI[md5sum] = "06e96ab7a5c652f8eaed6f71533a9e0f"
+SRC_URI[sha256sum] = "12f921f3dbe0f33c309f5f2891cccf5325c94bd48dceeb102de183f5f048a9e2"
+
+inherit pkgconfig
+
+EXTRA_OEMAKE = "\
+ -f '${S}/Makefile' \
+ \
+ 'PREFIX=${prefix}' \
+ 'SBINDIR=${sbindir}' \
+ 'MANDIR=${mandir}' \
+"
+B = "${WORKDIR}/build"
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}