summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2011-01-19 10:07:25 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-01-21 11:18:36 +0000
commitf2dc7fadd8c6b180c3f985873261216d53f47f0d (patch)
treef5dc544cc352312cac3b8907077a9dbabd32a5fe /meta/recipes-bsp
parentb6cbf223d838bca674301927d6c3ec48e349009b (diff)
downloadopenembedded-core-f2dc7fadd8c6b180c3f985873261216d53f47f0d.tar.gz
u-boot: Add a new upstream u-boot recipe
uboot-omap3 appears to be fairly stale (last commit in April 2010) while the upstream u-boot is making regular tagged releases. Add a new recipe using the upstream u-boot repository. Signed-off-by: Darren Hart <dvhart@linux.intel.com> CC: Tom Zanussi <tom.zanussi@intel.com> CC: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/uboot/u-boot.inc3
-rw-r--r--meta/recipes-bsp/uboot/u-boot_git.bb21
2 files changed, 23 insertions, 1 deletions
diff --git a/meta/recipes-bsp/uboot/u-boot.inc b/meta/recipes-bsp/uboot/u-boot.inc
index 889f6215ed..6363474e53 100644
--- a/meta/recipes-bsp/uboot/u-boot.inc
+++ b/meta/recipes-bsp/uboot/u-boot.inc
@@ -9,7 +9,8 @@ inherit deploy
PARALLEL_MAKE=""
-EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
+# GCC 4.5.1 builds unusable binaries using -Os, remove it from OPTFLAGS
+EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} OPTFLAGS=''"
UBOOT_MACHINE ?= "${MACHINE}_config"
UBOOT_IMAGE ?= "u-boot-${MACHINE}-${PV}-${PR}.bin"
diff --git a/meta/recipes-bsp/uboot/u-boot_git.bb b/meta/recipes-bsp/uboot/u-boot_git.bb
new file mode 100644
index 0000000000..16a1dbefae
--- /dev/null
+++ b/meta/recipes-bsp/uboot/u-boot_git.bb
@@ -0,0 +1,21 @@
+require u-boot.inc
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4c6cde5df68eff615d36789dc18edd3b \
+ file://README;beginline=1;endline=22;md5=3a00ef51d3fc96e9d6c1bc4708ccd3b5"
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/u-boot-git/${MACHINE}"
+
+PV = "v2010.12+${PR}+git${SRCPV}"
+PR="r0"
+
+SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
+
+UBOOT_MACHINE_beagleboard = "omap3_beagle_config"
+UBOOT_MACHINE_overo = "omap3_overo_config"
+
+S = "${WORKDIR}/git"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+COMPATIBLE_MACHINE = "(beagleboard|overo)"