summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2011-03-01 12:32:55 -0500
committerSaul Wold <sgw@linux.intel.com>2011-03-02 09:48:50 -0800
commitc34ac5c7536806a0d4f3c4af17f78ab711a8b408 (patch)
tree84fd445d705fbe9fc7ec7f64dd5213c48604918e /meta/recipes-bsp
parent231fcc8b5bbdab0ce5be552039a29c4d4400d996 (diff)
downloadopenembedded-core-c34ac5c7536806a0d4f3c4af17f78ab711a8b408.tar.gz
u-boot: remove do_install from u-boot.inc
Fixes [BUGID #777] The do_install rule in u-boot.inc was installing a host tool into the target ${bindir}, which is subsequently stripped with target strip during packaging, and the obvious error ensues. The native u-boot recipe has its own install rule, and the machine specific u-boot doesn't require mkimage or anything else in the do_install function. So we remove it completely until it is needed again. [sgw: PR bump] Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/uboot/u-boot.inc5
-rw-r--r--meta/recipes-bsp/uboot/u-boot_git.bb2
2 files changed, 1 insertions, 6 deletions
diff --git a/meta/recipes-bsp/uboot/u-boot.inc b/meta/recipes-bsp/uboot/u-boot.inc
index 1457c042e8..d1cebeedfb 100644
--- a/meta/recipes-bsp/uboot/u-boot.inc
+++ b/meta/recipes-bsp/uboot/u-boot.inc
@@ -31,8 +31,3 @@ do_deploy () {
ln -sf ${UBOOT_IMAGE} ${UBOOT_SYMLINK}
}
addtask deploy before do_build after do_compile
-
-do_install() {
- install -d ${D}${bindir}
- install -m 755 tools/mkimage ${D}${bindir}/
-}
diff --git a/meta/recipes-bsp/uboot/u-boot_git.bb b/meta/recipes-bsp/uboot/u-boot_git.bb
index b3207c68b0..4686a5875b 100644
--- a/meta/recipes-bsp/uboot/u-boot_git.bb
+++ b/meta/recipes-bsp/uboot/u-boot_git.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/u-boot-git/${MACHINE}"
PV = "v2010.12+${PR}+git${SRCPV}"
-PR="r0"
+PR="r1"
SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"