summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-fw-utils_2017.11.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2017-11-14 16:32:23 -0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-11-29 23:41:34 +0000
commit11413ee23f4eb3d52c1e9831f2c67f088370040a (patch)
tree3b18cfa20e10551d342574a6f2e2264c6530bad4 /meta/recipes-bsp/u-boot/u-boot-fw-utils_2017.11.bb
parent3ae6802f83f23881994531284c0ff1a27a8a7be9 (diff)
downloadopenembedded-core-11413ee23f4eb3d52c1e9831f2c67f088370040a.tar.gz
u-boot: Upgrade to 2017.11 release
This upgrades the U-Boot from 2017.09 to 2017.11 release. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-fw-utils_2017.11.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-fw-utils_2017.11.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2017.11.bb b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2017.11.bb
new file mode 100644
index 0000000000..02887a138a
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2017.11.bb
@@ -0,0 +1,34 @@
+require u-boot-common_${PV}.inc
+
+SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
+DEPENDS = "mtd-utils"
+
+INSANE_SKIP_${PN} = "already-stripped"
+EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
+EXTRA_OEMAKE_class-cross = 'HOSTCC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
+
+inherit uboot-config
+
+do_compile () {
+ oe_runmake ${UBOOT_MACHINE}
+ oe_runmake envtools
+}
+
+do_install () {
+ install -d ${D}${base_sbindir}
+ install -d ${D}${sysconfdir}
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
+ install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config
+}
+
+do_install_class-cross () {
+ install -d ${D}${bindir_cross}
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
+}
+
+SYSROOT_DIRS_append_class-cross = " ${bindir_cross}"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+BBCLASSEXTEND = "cross"