summaryrefslogtreecommitdiffstats
path: root/meta/lib/oeqa/runtime
diff options
context:
space:
mode:
authorFrederic Martinsons <frederic.martinsons@gmail.com>2023-08-02 15:16:05 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-08-09 13:21:27 +0100
commit8baaf94d200f5355791ecd980727698b1ab0e539 (patch)
tree58766e1e48d4de14bb29164db30536a2a3661cce /meta/lib/oeqa/runtime
parentb80f756dd480fc92f58d7e10105d3a2427a32795 (diff)
downloadopenembedded-core-8baaf94d200f5355791ecd980727698b1ab0e539.tar.gz
rust-hello-world: Drop recipe
we now have more rust/cargo recipes and tests that cover various use cases so this is no longer needed. Signed-off-by: Frederic Martinsons <frederic.martinsons@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/lib/oeqa/runtime')
-rw-r--r--meta/lib/oeqa/runtime/cases/rust.py12
1 files changed, 0 insertions, 12 deletions
diff --git a/meta/lib/oeqa/runtime/cases/rust.py b/meta/lib/oeqa/runtime/cases/rust.py
index c9c60e16fd..9bf0312669 100644
--- a/meta/lib/oeqa/runtime/cases/rust.py
+++ b/meta/lib/oeqa/runtime/cases/rust.py
@@ -48,15 +48,3 @@ class RustCompileTest(OERuntimeTestCase):
status, output = self.target.run('cargo run --manifest-path=/tmp/hello/Cargo.toml')
msg = 'running compiled file failed, output: %s' % output
self.assertEqual(status, 0, msg=msg)
-
-class RustHelloworldTest(OERuntimeTestCase):
- @OETestDepends(['ssh.SSHTest.test_ssh'])
- @OEHasPackage(['rust-hello-world'])
- def test_rusthelloworld(self):
- cmd = "rust-hello-world"
- status, output = self.target.run(cmd)
- msg = 'Exit status was not 0. Output: %s' % output
- self.assertEqual(status, 0, msg=msg)
-
- msg = 'Incorrect output: %s' % output
- self.assertEqual(output, "Hello, world!", msg=msg)