summaryrefslogtreecommitdiffstats
path: root/meta/lib/oe/sstatesig.py
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2023-08-05 11:04:47 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-08-09 13:23:26 +0100
commit4f1148eeab2500022d7e17feadf80027a01a51f1 (patch)
treece73a088d30bf6bf66133377c31d99600c8a4392 /meta/lib/oe/sstatesig.py
parent9e9c33d51e401fe2b4a632db74ccb3449e4b23ee (diff)
downloadopenembedded-core-4f1148eeab2500022d7e17feadf80027a01a51f1.tar.gz
sstatesig: Update to match bitbake changes to runtaskdeps
Bitbake has changes to runtaskdeps in siginfo files to fix bugs in being able to locate them for sstate and hash debugging purposes. This patch updates to match the changes to the format. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/lib/oe/sstatesig.py')
-rw-r--r--meta/lib/oe/sstatesig.py14
1 files changed, 9 insertions, 5 deletions
diff --git a/meta/lib/oe/sstatesig.py b/meta/lib/oe/sstatesig.py
index f943df181e..633a0fd450 100644
--- a/meta/lib/oe/sstatesig.py
+++ b/meta/lib/oe/sstatesig.py
@@ -215,6 +215,9 @@ class SignatureGeneratorOEBasicHashMixIn(object):
def dump_lockedsigs(self, sigfile, taskfilter=None):
types = {}
for tid in self.runtaskdeps:
+ # Bitbake changed this to a tuple in newer versions
+ if isinstance(tid, tuple):
+ tid = tid[1]
if taskfilter:
if not tid in taskfilter:
continue
@@ -321,11 +324,12 @@ def find_siginfo(pn, taskname, taskhashlist, d):
if not taskname:
# We have to derive pn and taskname
key = pn
- splitit = key.split('.bb:')
- taskname = splitit[1]
- pn = os.path.basename(splitit[0]).split('_')[0]
- if key.startswith('virtual:native:'):
- pn = pn + '-native'
+ if key.startswith("mc:"):
+ # mc:<mc>:<pn>:<task>
+ _, _, pn, taskname = key.split(':', 3)
+ else:
+ # <pn>:<task>
+ pn, taskname = key.split(':', 1)
hashfiles = {}
filedates = {}