aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2017-08-21 15:09:59 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-09-14 14:07:53 +0100
commite4b86c930d23b0581104788e4b0d29994f5b3bef (patch)
treec4d038d741dbf6ee350b603ce0d004e84d8a01fc
parent7fc6360dd874c9b6fb9cf785fb2dfe3aec55c9a7 (diff)
downloadopenembedded-core-master-next-2.5.tar.gz
hwlatdetect: fix RDEPENDS to avoid QA failuresmaster-next-2.5
When listing python3 as an RDEPENDS, the image will in fact contain python3-modules, but the QA check fails to get RPROVIDERS correctly (since the python3 package does not actually exist), /usr/bin/python3 is provided by the python3-core package, so by fixing the RDEPENDS and listing python3-core instead of python3, the QA check works correctly and we avoid failures. Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
-rw-r--r--meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb b/meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb
index 60b44a4d25..5f61c4ecdd 100644
--- a/meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb
+++ b/meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb
@@ -22,5 +22,5 @@ do_install() {
}
FILES_${PN} += "${libdir}/python${PYTHON_BASEVERSION}/dist-packages/hwlatdetect.py"
-RDEPENDS_${PN} = "python3 "
+RDEPENDS_${PN} = "python3-core "
RRECOMMENDS_${PN} = "kernel-module-hwlat-detector"