summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu/files/linker-flags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/qemu/files/linker-flags.patch')
-rw-r--r--meta/recipes-devtools/qemu/files/linker-flags.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-devtools/qemu/files/linker-flags.patch b/meta/recipes-devtools/qemu/files/linker-flags.patch
new file mode 100644
index 0000000000..0106ae2420
--- /dev/null
+++ b/meta/recipes-devtools/qemu/files/linker-flags.patch
@@ -0,0 +1,25 @@
+Fedora 13 switched the default behaviour of the linker to no longer
+indirectly link to required libraries (i.e. dependencies of a library
+already linked to). Therefore we need to explicitly pass the depended on
+libraries into the linker for building to work on Fedora 13.
+
+More information is available on the Fedora Wiki:
+https://fedoraproject.org/wiki/UnderstandingDSOLinkChange
+
+JL - 15/06/10
+
+Upstream-Status: Inappropriate [configuration]
+
+Index: qemu-1.2.0/Makefile.target
+===================================================================
+--- qemu-1.2.0.orig/Makefile.target 2012-09-05 07:03:06.000000000 -0700
++++ qemu-1.2.0/Makefile.target 2012-09-06 13:42:24.819764288 -0700
+@@ -130,7 +130,7 @@
+ obj-$(CONFIG_HAVE_CORE_DUMP) += dump.o
+ obj-$(CONFIG_NO_GET_MEMORY_MAPPING) += memory_mapping-stub.o
+ obj-$(CONFIG_NO_CORE_DUMP) += dump-stub.o
+-LIBS+=-lz
++LIBS+=-lz -lX11 -ldl
+
+ QEMU_CFLAGS += $(VNC_TLS_CFLAGS)
+ QEMU_CFLAGS += $(VNC_SASL_CFLAGS)