summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pip_9.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-pip_9.0.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pip_9.0.1.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pip_9.0.1.bb b/meta/recipes-devtools/python/python3-pip_9.0.1.bb
index b6dbb6e5f2..4456b9b1b1 100644
--- a/meta/recipes-devtools/python/python3-pip_9.0.1.bb
+++ b/meta/recipes-devtools/python/python3-pip_9.0.1.bb
@@ -34,6 +34,11 @@ do_install_append() {
# Installed eggs need to be passed directly to the interpreter via a pth file
echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}-${PV}.pth
+
+ # Make sure we use /usr/bin/env python3
+ for PYTHSCRIPT in `grep -rIl ${bindir} ${D}${bindir}/pip3*`; do
+ sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT
+ done
}
RDEPENDS_${PN} = "\
@@ -47,3 +52,5 @@ RDEPENDS_${PN} = "\
python3-unixadmin \
python3-xmlrpc \
"
+
+BBCLASSEXTEND = "native"