summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-mako_1.2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-mako_1.2.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-mako_1.2.1.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-mako_1.2.1.bb b/meta/recipes-devtools/python/python3-mako_1.2.1.bb
new file mode 100644
index 0000000000..8155c37984
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-mako_1.2.1.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Templating library for Python"
+HOMEPAGE = "http://www.makotemplates.org/"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ad08dd28df88e64b35bcac27c822ee34"
+
+PYPI_PACKAGE = "Mako"
+
+inherit pypi python_setuptools_build_meta
+
+SRC_URI[sha256sum] = "f054a5ff4743492f1aa9ecc47172cb33b42b9d993cffcc146c9de17e717b0307"
+
+RDEPENDS:${PN} = "${PYTHON_PN}-html \
+ ${PYTHON_PN}-markupsafe \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-pygments \
+ ${PYTHON_PN}-threading \
+"
+
+BBCLASSEXTEND = "native nativesdk"