aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-omap/0001-board-omap3beagle-whitespace-cleanup.patch
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2011-06-06 13:43:56 -0700
committerDarren Hart <dvhart@linux.intel.com>2011-06-07 09:31:57 -0700
commit9b07424ee00844c4a78ecd1dca83f8d8d4fd6197 (patch)
treea0d709a6f040f9616e31bee97b13a10c1072ae67 /recipes-kernel/linux/linux-omap/0001-board-omap3beagle-whitespace-cleanup.patch
parent675b2a2a54f1bb4b805f61dfc3eba3b5683fee93 (diff)
downloadopenembedded-core-contrib-dvhart/beagleboard.tar.gz
beagleboard: cleanup board-omap3beagle.c and allow for building without wl1271dvhart/beagleboard
Add two patches to the linux-omap_2.6.37.bb recipe. The first corrects some whitespace usage. The second adds an ifdef arround the usage of symbols from the wl1271 driver, allowing the beagleboard kernel to be built without that driver configured. Signed-off-by: Darren Hart <dvhart@linux.intel.com> Cc: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-kernel/linux/linux-omap/0001-board-omap3beagle-whitespace-cleanup.patch')
-rw-r--r--recipes-kernel/linux/linux-omap/0001-board-omap3beagle-whitespace-cleanup.patch91
1 files changed, 91 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-omap/0001-board-omap3beagle-whitespace-cleanup.patch b/recipes-kernel/linux/linux-omap/0001-board-omap3beagle-whitespace-cleanup.patch
new file mode 100644
index 0000000000..69105575f5
--- /dev/null
+++ b/recipes-kernel/linux/linux-omap/0001-board-omap3beagle-whitespace-cleanup.patch
@@ -0,0 +1,91 @@
+From e5e52482147151aaaafbd388d1e5978268e51d24 Mon Sep 17 00:00:00 2001
+Message-Id: <e5e52482147151aaaafbd388d1e5978268e51d24.1307392642.git.dvhart@linux.intel.com>
+From: Darren Hart <dvhart@linux.intel.com>
+Date: Mon, 6 Jun 2011 10:17:56 -0700
+Subject: [PATCH 1/2] board-omap3beagle: whitespace cleanup
+
+Eliminate leading and trailing whitespace.
+Indent with tabs.
+
+Signed-off-by: Darren Hart <dvhart@linux.intel.com>
+---
+ arch/arm/mach-omap2/board-omap3beagle.c | 28 ++++++++++++++--------------
+ 1 files changed, 14 insertions(+), 14 deletions(-)
+
+diff --git a/arch/arm/mach-omap2/board-omap3beagle.c b/arch/arm/mach-omap2/board-omap3beagle.c
+index b035bb5..b618cb6 100644
+--- a/arch/arm/mach-omap2/board-omap3beagle.c
++++ b/arch/arm/mach-omap2/board-omap3beagle.c
+@@ -167,12 +167,12 @@ struct wl12xx_platform_data omap_beagle_wlan_data __initdata = {
+ .board_ref_clock = 2, /* 38.4 MHz */
+ };
+
+- static struct omap2_hsmmc_info mmcbbt[] = {
+- {
+- .mmc = 1,
+- .caps = MMC_CAP_4_BIT_DATA | MMC_CAP_8_BIT_DATA,
+- .gpio_wp = 29,
+- },
++static struct omap2_hsmmc_info mmcbbt[] = {
++ {
++ .mmc = 1,
++ .caps = MMC_CAP_4_BIT_DATA | MMC_CAP_8_BIT_DATA,
++ .gpio_wp = 29,
++ },
+ {
+ .name = "wl1271",
+ .mmc = 2,
+@@ -181,8 +181,8 @@ struct wl12xx_platform_data omap_beagle_wlan_data __initdata = {
+ .gpio_cd = -EINVAL,
+ .nonremovable = true,
+ },
+- {} /* Terminator */
+- };
++ {} /* Terminator */
++};
+
+ static struct regulator_consumer_supply beagle_vmmc2_supply = {
+ .supply = "vmmc",
+@@ -455,7 +455,7 @@ static int beagle_twl_gpio_setup(struct device *dev,
+ /* gpio + 0 is "mmc0_cd" (input/IRQ) */
+ mmc[0].gpio_cd = gpio + 0;
+ #if defined(CONFIG_WL1271) || defined(CONFIG_WL1271_MODULE)
+- if(!strcmp(expansionboard_name, "bbtoys-wifi")) {
++ if(!strcmp(expansionboard_name, "bbtoys-wifi")) {
+ omap2_hsmmc_init(mmcbbt);
+ /* link regulators to MMC adapters */
+ beagle_vmmc1_supply.dev = mmcbbt[0].dev;
+@@ -648,9 +648,9 @@ static struct i2c_board_info __initdata beagle_i2c1_boardinfo[] = {
+ };
+
+ static struct i2c_board_info __initdata beagle_i2c_eeprom[] = {
+- {
+- I2C_BOARD_INFO("eeprom", 0x50),
+- },
++ {
++ I2C_BOARD_INFO("eeprom", 0x50),
++ },
+ };
+
+ #if defined(CONFIG_RTC_DRV_DS1307) || \
+@@ -888,7 +888,7 @@ static void __init omap3_beagle_init(void)
+ /* REVISIT leave DVI powered down until it's needed ... */
+ gpio_direction_output(170, true);
+
+- if(!strcmp(expansionboard_name, "zippy"))
++ if(!strcmp(expansionboard_name, "zippy"))
+ {
+ printk(KERN_INFO "Beagle expansionboard: initializing enc28j60\n");
+ omap3beagle_enc28j60_init();
+@@ -897,7 +897,7 @@ static void __init omap3_beagle_init(void)
+ mmc[1].gpio_cd = 162;
+ }
+
+- if(!strcmp(expansionboard_name, "zippy2"))
++ if(!strcmp(expansionboard_name, "zippy2"))
+ {
+ printk(KERN_INFO "Beagle expansionboard: initializing ks_8851\n");
+ omap3beagle_ks8851_init();
+--
+1.7.1
+