summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/perf/perf.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-12-10 12:03:42 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-12-12 11:27:19 +0000
commit33828620872b80e1c745612e025215666ba755c8 (patch)
treec1c06bc5c5ae7c5fd378c3122233d46ddde0ccc2 /meta/recipes-kernel/perf/perf.bb
parent259bcfdac3ad87d269dd18617c784fe14c50b0ad (diff)
downloadopenembedded-core-contrib-33828620872b80e1c745612e025215666ba755c8.tar.gz
perf: Tweak for mips n64
With the changes to binutils, perf's direct calls to ld break for mips n64. We already have tweaks for n32 so match those with the ones for n64. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/perf/perf.bb')
-rw-r--r--meta/recipes-kernel/perf/perf.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 7bbc1ad70c..ec0c6efe15 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -125,9 +125,11 @@ PERF_SRC ?= "Makefile \
PERF_EXTRA_LDFLAGS = ""
-# MIPS N32
+# MIPS N32/N64
PERF_EXTRA_LDFLAGS:mipsarchn32eb = "-m elf32btsmipn32"
PERF_EXTRA_LDFLAGS:mipsarchn32el = "-m elf32ltsmipn32"
+PERF_EXTRA_LDFLAGS:mipsarchn64eb = "-m elf64btsmip"
+PERF_EXTRA_LDFLAGS:mipsarchn64el = "-m elf64ltsmip"
do_compile() {
# Linux kernel build system is expected to do the right thing