summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-modules_git.bb
diff options
context:
space:
mode:
authorEmilia Ciobanu <emilia.maria.silvia.ciobanu@intel.com>2013-07-08 16:37:23 +0300
committerSaul Wold <sgw@linux.intel.com>2013-07-22 09:44:09 -0700
commit07ca5da4da59a0069e7b8a18e7589e3674f2616c (patch)
tree4dabe3a8c954442d2d188d78f97950e3ec25b4d3 /meta/recipes-kernel/lttng/lttng-modules_git.bb
parent70d0938c304cd49e08cbcb28e391e7ace8e666e0 (diff)
downloadopenembedded-core-contrib-07ca5da4da59a0069e7b8a18e7589e3674f2616c.tar.gz
lttng-modules: Append _git to recipe name and add GIT revision to PV
variable Git packages should have the following format for the PV variable: version_tag+git[r|\-|]?AUTOINC+git_revision Signed-off-by: Emilia Ciobanu <emilia.maria.silvia.ciobanu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_git.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_git.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_git.bb b/meta/recipes-kernel/lttng/lttng-modules_git.bb
new file mode 100644
index 0000000000..3a92879e3c
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-modules_git.bb
@@ -0,0 +1,34 @@
+SECTION = "devel"
+SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
+DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
+LICENSE = "LGPLv2.1 & GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1412caf5a1aa90d6a48588a4794c0eac \
+ file://gpl-2.0.txt;md5=751419260aa954499f7abaabaa882bbe \
+ file://lgpl-2.1.txt;md5=243b725d71bb5df4a1e5920b344b86ad"
+
+DEPENDS = "virtual/kernel"
+
+inherit module
+
+SRCREV = "1b26381c19dd2d9fa41f52d8dc13b15b8dd32c7c"
+PV = "2.2.0+git${SRCPV}"
+
+SRC_URI = "git://git.lttng.org/lttng-modules.git;protocol=git \
+ file://lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch"
+
+export INSTALL_MOD_DIR="kernel/lttng-modules"
+export KERNEL_SRC="${STAGING_KERNEL_DIR}"
+
+
+S = "${WORKDIR}/git"
+
+do_install_append() {
+ # Delete empty directories to avoid QA failures if no modules were built
+ find ${D}/lib -depth -type d -empty -exec rmdir {} \;
+}
+
+python do_package_prepend() {
+ if not os.path.exists(os.path.join(d.getVar('D', True), 'lib/modules')):
+ bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN', True))
+}
+