summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-02-17 17:09:19 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-02-17 17:56:52 +0000
commit550be77683805f2853a49cfe79584e9bf925f53d (patch)
tree78de70ee346d756261c7f88c7a21aa8c6ddbf7ab /meta/recipes-extended
parentd9de00cd5228d42f628af455ad42c06a0883f6d0 (diff)
downloadopenembedded-core-contrib-550be77683805f2853a49cfe79584e9bf925f53d.tar.gz
man-db: update 2.10.0 -> 2.10.1
Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/man-db/files/0001-man-Move-local-variable-declaration-to-function-scop.patch20
-rw-r--r--meta/recipes-extended/man-db/man-db_2.10.1.bb (renamed from meta/recipes-extended/man-db/man-db_2.10.0.bb)6
2 files changed, 10 insertions, 16 deletions
diff --git a/meta/recipes-extended/man-db/files/0001-man-Move-local-variable-declaration-to-function-scop.patch b/meta/recipes-extended/man-db/files/0001-man-Move-local-variable-declaration-to-function-scop.patch
index 820b17b5de..dc6966629c 100644
--- a/meta/recipes-extended/man-db/files/0001-man-Move-local-variable-declaration-to-function-scop.patch
+++ b/meta/recipes-extended/man-db/files/0001-man-Move-local-variable-declaration-to-function-scop.patch
@@ -1,4 +1,4 @@
-From 4b5e00ad020ec327cbc934528d02aa8c4fe3910b Mon Sep 17 00:00:00 2001
+From 126dfefb5fddf411ad0a1316209e9c1b47abfcd2 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Wed, 9 Feb 2022 17:30:16 -0800
Subject: [PATCH] man: Move local variable declaration to function scope
@@ -10,12 +10,13 @@ code without changing the logic, until its fixed in clang
Upstream-Status: Inappropriate [Inappropriate: Clang bug]
Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
---
src/man.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/man.c b/src/man.c
-index c91abf1..3240eea 100644
+index f16fae8..333df03 100644
--- a/src/man.c
+++ b/src/man.c
@@ -352,7 +352,7 @@ static void init_html_pager (void)
@@ -27,15 +28,12 @@ index c91abf1..3240eea 100644
/* Please keep these keys in the same order as in options above. */
switch (key) {
case 'C':
-@@ -383,7 +383,7 @@ static error_t parse_opt (int key, char *arg, struct argp_state *state)
-
+@@ -384,7 +384,7 @@ static error_t parse_opt (int key, char *arg, struct argp_state *state)
case OPT_WARNINGS:
#ifdef NROFF_WARNINGS
-- char *s = xstrdup (arg ? arg : default_roff_warnings);
-+ s = xstrdup (arg ? arg : default_roff_warnings);
- const char *warning;
+ {
+- char *s = xstrdup
++ s = xstrdup
+ (arg ? arg : default_roff_warnings);
+ const char *warning;
- for (warning = strtok (s, ","); warning;
---
-2.35.1
-
diff --git a/meta/recipes-extended/man-db/man-db_2.10.0.bb b/meta/recipes-extended/man-db/man-db_2.10.1.bb
index a604930198..897f8d8ce0 100644
--- a/meta/recipes-extended/man-db/man-db_2.10.0.bb
+++ b/meta/recipes-extended/man-db/man-db_2.10.1.bb
@@ -9,11 +9,7 @@ SRC_URI = "${SAVANNAH_NONGNU_MIRROR}/man-db/man-db-${PV}.tar.xz \
file://99_mandb \
file://0001-man-Move-local-variable-declaration-to-function-scop.patch \
file://man_db.conf-avoid-multilib-install-file-conflict.patch"
-SRC_URI[sha256sum] = "0a8629022f7117dc7fc6473c6fdb14913b24b106059bb056abee87dbd6070c79"
-
-# remove at next version upgrade or when output changes
-PR = "r1"
-HASHEQUIV_HASH_VERSION .= ".2"
+SRC_URI[sha256sum] = "2ffd8f2e80122fe72e60c740c851e6a3e15c9a7921185eb4752c1c672824bed6"
DEPENDS = "libpipeline gdbm groff-native base-passwd"
RDEPENDS:${PN} += "base-passwd"