summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gcc/gcc_5.4.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-24 23:52:06 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-26 10:41:08 +0000
commit626064c69b6fd1b5cead6995097f99e5fbda3f19 (patch)
tree25322e352d50621e625c98b373bc817509e3cf19 /meta/recipes-devtools/gcc/gcc_5.4.bb
parentdcf15ccf3cc9d55e77228ba8d526f967fc9791b4 (diff)
downloadopenembedded-core-contrib-626064c69b6fd1b5cead6995097f99e5fbda3f19.tar.gz
gcc/gcc-source: Move libcc1 manipulation into gcc-source
Currently there is a race where if you build -cross-canadian without building gcc (target) you see QA errors about RPATHS. I've tracked this down to this manipulation where the target gcc recipe changes libcc1 in the shared sources directory. As long as you build things in the right order, the problem doesn't occur. Since its changing ${S} move it to gcc-source and avoid the race, saving RP some head scratching about why unrelated changes failed to build cleanly. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/gcc/gcc_5.4.bb')
-rw-r--r--meta/recipes-devtools/gcc/gcc_5.4.bb6
1 files changed, 0 insertions, 6 deletions
diff --git a/meta/recipes-devtools/gcc/gcc_5.4.bb b/meta/recipes-devtools/gcc/gcc_5.4.bb
index b0a523cae2..2c618dfb93 100644
--- a/meta/recipes-devtools/gcc/gcc_5.4.bb
+++ b/meta/recipes-devtools/gcc/gcc_5.4.bb
@@ -6,10 +6,4 @@ require gcc-target.inc
# | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7442:(.text.unlikely+0x318): additional relocation overflows omitted from the output
ARM_INSTRUCTION_SET_armv4 = "arm"
-do_configure_prepend() {
- # Easiest way to stop bad RPATHs getting into the library since we have a
- # broken libtool here
- sed -i -e 's/hardcode_into_libs=yes/hardcode_into_libs=no/' ${S}/libcc1/configure
-}
-
BBCLASSEXTEND = "nativesdk"