aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-fw-utils-cross_2013.07.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2013-09-04 21:39:11 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-09-10 16:01:07 +0100
commitc5fff5748e0aaf7e135fdd464c2104b1d3cbfd5a (patch)
treeaf74a48255f11626ae0db6edcb42ab62d5439bac /meta/recipes-bsp/u-boot/u-boot-fw-utils-cross_2013.07.bb
parent6126c6e4b9c40c222519914c8fe0a51f9eee8d41 (diff)
downloadopenembedded-core-contrib-c5fff5748e0aaf7e135fdd464c2104b1d3cbfd5a.tar.gz
u-boot, u-boot-fw-utils-cross, u-boot-mkimage: Upgrade to 2013.07
This upgrades the U-Boot based recipes for 2013.07 release. This removes the 2011.03, 2011.06 and 2013.01.01 versions so we keep a single one in core. The following recipes has been upgraded: - u-boot (remove old versions) - u-boot-mkimage (remove old versions) - u-boot-fw-utils -> u-boot-fw-utils-cross (renamed and reworked) The u-boot-fw-utils-cross recipe has been reworked as it uses the UBOOT_MACHINE to find default environment for use so it is indeed a cross binary and not a native one. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-fw-utils-cross_2013.07.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-fw-utils-cross_2013.07.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-fw-utils-cross_2013.07.bb b/meta/recipes-bsp/u-boot/u-boot-fw-utils-cross_2013.07.bb
new file mode 100644
index 0000000000..7f649caac3
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-fw-utils-cross_2013.07.bb
@@ -0,0 +1,38 @@
+DESCRIPTION = "U-boot bootloader fw_printenv/setenv utils"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
+SECTION = "bootloader"
+DEPENDS = "mtd-utils"
+
+# This revision corresponds to the tag "v2013.07"
+# We use the revision in order to avoid having to fetch it from the
+# repo during parse
+SRCREV = "62c175fbb8a0f9a926c88294ea9f7e88eb898f6c"
+
+PV = "v2013.07+git${SRCPV}"
+
+SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
+
+S = "${WORKDIR}/git"
+
+inherit cross
+
+EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"'
+
+do_compile () {
+ oe_runmake ${UBOOT_MACHINE}
+ oe_runmake env
+}
+
+do_install () {
+ install -d ${D}${bindir_cross}
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
+}
+
+SYSROOT_PREPROCESS_FUNCS = "uboot_fw_utils_cross"
+uboot_fw_utils_cross() {
+ sysroot_stage_dir ${D}${bindir_cross} ${SYSROOT_DESTDIR}${bindir_cross}
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"