summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJorn Baayen <jorn@openedhand.com>2006-07-20 10:43:56 +0000
committerJorn Baayen <jorn@openedhand.com>2006-07-20 10:43:56 +0000
commiteefc8d5e324124c260809a4ac1b2b75d5139e881 (patch)
treeb0aa1594f32082d486bf3423af1da3c850f7d06d
parent1c3a546c0aefd3b2f107a3aad28613ab570e7ad4 (diff)
downloadopenembedded-core-contrib-eefc8d5e324124c260809a4ac1b2b75d5139e881.tar.gz
added glib 2.12 (needed for gtk 2.10 + decairoification patches)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@516 311d38ba-8fff-0310-9ca6-ca027cbcb966
-rw-r--r--openembedded/packages/glib-2.0/glib-2.0-native_2.12.0.bb54
-rw-r--r--openembedded/packages/glib-2.0/glib-2.0_2.12.0.bb47
2 files changed, 101 insertions, 0 deletions
diff --git a/openembedded/packages/glib-2.0/glib-2.0-native_2.12.0.bb b/openembedded/packages/glib-2.0/glib-2.0-native_2.12.0.bb
new file mode 100644
index 0000000000..768f2777d8
--- /dev/null
+++ b/openembedded/packages/glib-2.0/glib-2.0-native_2.12.0.bb
@@ -0,0 +1,54 @@
+DESCRIPTION = "GLib is a general-purpose utility library, \
+which provides many useful data types, macros, \
+type conversions, string utilities, file utilities, a main \
+loop abstraction, and so on. It works on many \
+UNIX-like platforms, Windows, OS/2 and BeOS."
+LICENSE = "LGPL"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS += "gtk-doc-native"
+PR="r1"
+
+EXTRA_OECONF = "--disable-debug"
+
+SRC_URI = "http://download.gnome.org/sources/glib/2.12/glib-${PV}.tar.bz2 \
+ file://glib-gettextize-dir.patch;patch=1 \
+ file://glibconfig-sysdefs.h"
+
+S = "${WORKDIR}/glib-${PV}"
+
+inherit autotools pkgconfig native gettext
+
+python () {
+ if bb.data.getVar("USE_NLS", d, 1) == "no":
+ raise bb.parse.SkipPackage("${PN} requires native language support.")
+}
+
+acpaths = ""
+do_configure_prepend () {
+ install -m 0644 ${WORKDIR}/glibconfig-sysdefs.h .
+}
+
+do_stage () {
+ install -m 0755 gobject/glib-mkenums ${STAGING_BINDIR}/
+ install -m 0755 gobject/.libs/glib-genmarshal ${STAGING_BINDIR}/
+ install -m 0755 glib-gettextize ${STAGING_BINDIR}/
+ oe_libinstall -so -C glib libglib-2.0 ${STAGING_LIBDIR}
+ oe_libinstall -so -C gmodule libgmodule-2.0 ${STAGING_LIBDIR}
+ oe_libinstall -so -C gthread libgthread-2.0 ${STAGING_LIBDIR}
+ oe_libinstall -so -C gobject libgobject-2.0 ${STAGING_LIBDIR}
+ autotools_stage_includes
+ install -d ${STAGING_INCDIR}/glib-2.0/glib
+ install -m 0755 ${S}/glibconfig.h ${STAGING_INCDIR}/glib-2.0/glibconfig.h
+ install -d ${STAGING_DATADIR}/aclocal
+ install -m 0644 ${S}/m4macros/glib-2.0.m4 ${STAGING_DATADIR}/aclocal/glib-2.0.m4
+ install -m 0644 ${S}/m4macros/glib-gettext.m4 ${STAGING_DATADIR}/aclocal/glib-gettext.m4
+ install -d ${STAGING_DATADIR}/glib-2.0/gettext/po
+ install -m 0755 mkinstalldirs ${STAGING_DATADIR}/glib-2.0/gettext/
+ install -m 0644 po/Makefile.in.in ${STAGING_DATADIR}/glib-2.0/gettext/po/
+}
+
+do_install () {
+ :
+}
+
diff --git a/openembedded/packages/glib-2.0/glib-2.0_2.12.0.bb b/openembedded/packages/glib-2.0/glib-2.0_2.12.0.bb
new file mode 100644
index 0000000000..31d7347a06
--- /dev/null
+++ b/openembedded/packages/glib-2.0/glib-2.0_2.12.0.bb
@@ -0,0 +1,47 @@
+DESCRIPTION = "GLib is a general-purpose utility library, \
+which provides many useful data types, macros, \
+type conversions, string utilities, file utilities, a main \
+loop abstraction, and so on. It works on many \
+UNIX-like platforms, Windows, OS/2 and BeOS."
+LICENSE = "LGPL"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS += "glib-2.0-native gtk-doc"
+DEPENDS += "virtual/libiconv virtual/libintl"
+PACKAGES =+ "glib-2.0-utils "
+PR = "r1"
+
+LEAD_SONAME = "libglib-2.0.*"
+FILES_glib-2.0-utils = "${bindir}/*"
+
+EXTRA_OECONF = "--disable-debug"
+
+SRC_URI = "http://download.gnome.org/sources/glib/2.12/glib-${PV}.tar.bz2 \
+ file://glibconfig-sysdefs.h"
+
+S = "${WORKDIR}/glib-${PV}"
+
+inherit autotools pkgconfig gettext
+
+python () {
+ if bb.data.getVar("USE_NLS", d, 1) == "no":
+ raise bb.parse.SkipPackage("${PN} requires native language support.")
+}
+
+acpaths = ""
+do_configure_prepend () {
+ install -m 0644 ${WORKDIR}/glibconfig-sysdefs.h .
+}
+
+do_stage () {
+ oe_libinstall -so -C glib libglib-2.0 ${STAGING_LIBDIR}
+ oe_libinstall -so -C gmodule libgmodule-2.0 ${STAGING_LIBDIR}
+ oe_libinstall -so -C gthread libgthread-2.0 ${STAGING_LIBDIR}
+ oe_libinstall -so -C gobject libgobject-2.0 ${STAGING_LIBDIR}
+ autotools_stage_includes
+ install -d ${STAGING_INCDIR}/glib-2.0/glib
+ install -m 0755 ${S}/glibconfig.h ${STAGING_INCDIR}/glib-2.0/glibconfig.h
+ install -d ${STAGING_DATADIR}/aclocal
+ install -m 0644 ${S}/m4macros/glib-2.0.m4 ${STAGING_DATADIR}/aclocal/glib-2.0.m4
+ install -m 0644 ${S}/m4macros/glib-gettext.m4 ${STAGING_DATADIR}/aclocal/glib-gettext.m4
+}