summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro del Castillo <alejandro.delcastillo@ni.com>2019-12-18 14:00:28 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-12-28 23:25:34 +0000
commite795ba18613a3f45a81617207abc68f93039cbe5 (patch)
treef955ef5c0a0743e6f776df029705b6ae4d78f3ae
parentbf51a4a1312562cc9b5944b7dfccba0b3d11dc3c (diff)
downloadopenembedded-core-contrib-e795ba18613a3f45a81617207abc68f93039cbe5.tar.gz
opkg: upgrade to version 0.4.2
- Drop open_inner.patch - Drop opkg_archive.patch - Remove "remove_test_binaries" function Signed-off-by: Alejandro del Castillo <alejandro.delcastillo@ni.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/opkg/opkg/open_inner.patch46
-rw-r--r--meta/recipes-devtools/opkg/opkg/opkg_archive.patch54
-rw-r--r--meta/recipes-devtools/opkg/opkg_0.4.2.bb (renamed from meta/recipes-devtools/opkg/opkg_0.4.1.bb)18
3 files changed, 3 insertions, 115 deletions
diff --git a/meta/recipes-devtools/opkg/opkg/open_inner.patch b/meta/recipes-devtools/opkg/opkg/open_inner.patch
deleted file mode 100644
index 278e099e3a..0000000000
--- a/meta/recipes-devtools/opkg/opkg/open_inner.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From alejandro.delcastillo@ni.com Wed Nov 20 22:35:02 2019
-From: Alejandro del Castillo <alejandro.delcastillo@ni.com>
-To: <opkg-devel@googlegroups.com>, <richard.purdie@linuxfoundation.org>
-CC: Alejandro del Castillo <alejandro.delcastillo@ni.com>
-Subject: [opkg][PATCH 2/2] open_inner: add support for empty payloads
-Date: Wed, 20 Nov 2019 16:34:48 -0600
-Message-ID: <20191120223448.26522-3-alejandro.delcastillo@ni.com>
-X-Mailer: git-send-email 2.22.0
-In-Reply-To: <20191120223448.26522-1-alejandro.delcastillo@ni.com>
-References: <20191120223448.26522-1-alejandro.delcastillo@ni.com>
-MIME-Version: 1.0
-Content-Type: text/plain
-Content-Transfer-Encoding: 8bit
-
-Support for empty compressed payloads need to be explicitly enabled on
-libarchive.
-
-Signed-off-by: Alejandro del Castillo <alejandro.delcastillo@ni.com>
-
-Upstream-Status: Backport
----
- libopkg/opkg_archive.c | 7 +++++++
- 1 file changed, 7 insertions(+)
-
-diff --git a/libopkg/opkg_archive.c b/libopkg/opkg_archive.c
-index 0e9ccea..f19cece 100644
---- a/libopkg/opkg_archive.c
-+++ b/libopkg/opkg_archive.c
-@@ -618,6 +618,13 @@ static struct archive *open_inner(struct archive *outer)
- goto err_cleanup;
- }
-
-+ r = archive_read_support_format_empty(inner);
-+ if (r != ARCHIVE_OK) {
-+ opkg_msg(ERROR, "Empty format not supported: %s\n",
-+ archive_error_string(inner));
-+ goto err_cleanup;
-+ }
-+
- r = archive_read_open(inner, data, NULL, inner_read, inner_close);
- if (r != ARCHIVE_OK) {
- opkg_msg(ERROR, "Failed to open inner archive: %s\n",
---
-2.22.0
-
-
diff --git a/meta/recipes-devtools/opkg/opkg/opkg_archive.patch b/meta/recipes-devtools/opkg/opkg/opkg_archive.patch
deleted file mode 100644
index 3e1ebae953..0000000000
--- a/meta/recipes-devtools/opkg/opkg/opkg_archive.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From alejandro.delcastillo@ni.com Wed Nov 20 22:35:01 2019
-Return-Path: <richard.purdie+caf_=rpurdie=rpsys.net@linuxfoundation.org>
-From: Alejandro del Castillo <alejandro.delcastillo@ni.com>
-To: <opkg-devel@googlegroups.com>, <richard.purdie@linuxfoundation.org>
-CC: Alejandro del Castillo <alejandro.delcastillo@ni.com>
-Subject: [opkg][PATCH 1/2] opkg_archive.c: avoid double free on uncompress
- error
-Date: Wed, 20 Nov 2019 16:34:47 -0600
-Message-ID: <20191120223448.26522-2-alejandro.delcastillo@ni.com>
-X-Mailer: git-send-email 2.22.0
-In-Reply-To: <20191120223448.26522-1-alejandro.delcastillo@ni.com>
-References: <20191120223448.26522-1-alejandro.delcastillo@ni.com>
-MIME-Version: 1.0
-Content-Type: text/plain
-Content-Transfer-Encoding: 8bit
-
-The open-inner function calls archive_read_open. On error,
-archive_read_open calls inner_close, which also closes the outter
-archive. On error, return NULL directly to avoid double free.
-
-
-Upstream-Status: Backport
-
-Signed-off-by: Alejandro del Castillo <alejandro.delcastillo@ni.com>
----
- libopkg/opkg_archive.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/libopkg/opkg_archive.c b/libopkg/opkg_archive.c
-index 3d87db1..0e9ccea 100644
---- a/libopkg/opkg_archive.c
-+++ b/libopkg/opkg_archive.c
-@@ -622,7 +622,7 @@ static struct archive *open_inner(struct archive *outer)
- if (r != ARCHIVE_OK) {
- opkg_msg(ERROR, "Failed to open inner archive: %s\n",
- archive_error_string(inner));
-- goto err_cleanup;
-+ return NULL;
- }
-
- return inner;
-@@ -683,7 +683,7 @@ static struct archive *extract_outer(const char *filename, const char *arname)
-
- inner = open_inner(outer);
- if (!inner)
-- goto err_cleanup;
-+ return NULL;
-
- return inner;
-
---
-2.22.0
-
-
diff --git a/meta/recipes-devtools/opkg/opkg_0.4.1.bb b/meta/recipes-devtools/opkg/opkg_0.4.2.bb
index 00ae9c74c2..66a74dc5ed 100644
--- a/meta/recipes-devtools/opkg/opkg_0.4.1.bb
+++ b/meta/recipes-devtools/opkg/opkg_0.4.2.bb
@@ -5,7 +5,7 @@ HOMEPAGE = "http://code.google.com/p/opkg/"
BUGTRACKER = "http://code.google.com/p/opkg/issues/list"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
- file://src/opkg.c;beginline=4;endline=18;md5=9f5a1ad5395378a807d6d591e2f92d25"
+ file://src/opkg.c;beginline=4;endline=18;md5=d6200b0f2b41dee278aa5fad333eecae"
DEPENDS = "libarchive"
@@ -14,13 +14,11 @@ PE = "1"
SRC_URI = "http://downloads.yoctoproject.org/releases/${BPN}/${BPN}-${PV}.tar.gz \
file://opkg.conf \
file://0001-opkg_conf-create-opkg.lock-in-run-instead-of-var-run.patch \
- file://opkg_archive.patch \
- file://open_inner.patch \
file://run-ptest \
"
-SRC_URI[md5sum] = "ba0c21305fc93b26e844981ef100dc85"
-SRC_URI[sha256sum] = "45ac1e037d3877f635d883f8a555e172883a25d3eeb7986c75890fdd31250a43"
+SRC_URI[md5sum] = "bd13e5dfc1c2536f0c7b2e15f795278e"
+SRC_URI[sha256sum] = "86887852c43457edfff9d8b6d9520f3f1cdd55f25eb600a6eb31e1c4e151e106"
# This needs to be before ptest inherit, otherwise all ptest files end packaged
# in libopkg package if OPKGLIBDIR == libdir, because default
@@ -47,16 +45,6 @@ PACKAGECONFIG[libsolv] = "--with-libsolv,--without-libsolv,libsolv"
EXTRA_OECONF += " --disable-pathfinder"
EXTRA_OECONF_class-native = "--localstatedir=/${@os.path.relpath('${localstatedir}', '${STAGING_DIR_NATIVE}')} --sysconfdir=/${@os.path.relpath('${sysconfdir}', '${STAGING_DIR_NATIVE}')}"
-# Release tarball has unused binaries on the tests folder, automatically created by automake.
-# For now, delete them to avoid packaging errors (wrong architecture)
-do_unpack_append () {
- bb.build.exec_func('remove_test_binaries', d)
-}
-
-remove_test_binaries () {
- rm ${WORKDIR}/opkg-${PV}/tests/libopkg_test*
-}
-
do_install_append () {
install -d ${D}${sysconfdir}/opkg
install -m 0644 ${WORKDIR}/opkg.conf ${D}${sysconfdir}/opkg/opkg.conf