summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-07-29 15:28:01 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-23 15:26:00 +0100
commite33aaed01b1b26d8ea22fc87afe436a93b64a790 (patch)
treef22f4c9bea6e9f46f51049bf73124a478d256b95
parente5190cdcf4efe5e80967bded13ef8e530811b0ec (diff)
downloadopenembedded-core-contrib-e33aaed01b1b26d8ea22fc87afe436a93b64a790.tar.gz
gdb: Cache gnu gettext config vars for musl builds
intl is used in gdb as well and we run the configure for it when running do compile. So we need to insert these caching of variables to extra oe_make (From OE-Core rev: 60de4d6c717c6a5131b02de29234d53a6ca1b993) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta/recipes-devtools/gdb/gdb_7.10.1.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gdb/gdb_7.10.1.bb b/meta/recipes-devtools/gdb/gdb_7.10.1.bb
index f897e1213e..47caf8e235 100644
--- a/meta/recipes-devtools/gdb/gdb_7.10.1.bb
+++ b/meta/recipes-devtools/gdb/gdb_7.10.1.bb
@@ -3,6 +3,11 @@ require gdb-${PV}.inc
inherit python-dir
+EXTRA_OEMAKE_append_libc-musl = "\
+ gt_cv_func_gnugettext1_libc=yes \
+ gt_cv_func_gnugettext2_libc=yes \
+ "
+
do_configure_prepend() {
if [ -n "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python', '', d)}" ]; then
cat > ${WORKDIR}/python << EOF