summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-06-30 13:32:23 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-06-30 13:32:23 +0000
commitbc194fe321f262c1081bbbd0b2176488578d57f0 (patch)
treed903d5ebbe84ed546f485809387680d01f03cc0a
parent5ec2c0bcdf7c05cc51ff88d37fc4262d3a73f82e (diff)
downloadopenembedded-core-contrib-bc194fe321f262c1081bbbd0b2176488578d57f0.tar.gz
apt-native: remove db-native and curl-native dependencies
idea from: http://excogito.wordpress.com/2008/06/30/hacks-to-reduce-pokylinux-build-time/ git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4747 311d38ba-8fff-0310-9ca6-ca027cbcb966
-rw-r--r--meta/packages/apt/apt-native.inc3
-rw-r--r--meta/packages/apt/apt-native_0.7.14.bb5
-rw-r--r--meta/packages/apt/files/no-curl.patch44
3 files changed, 48 insertions, 4 deletions
diff --git a/meta/packages/apt/apt-native.inc b/meta/packages/apt/apt-native.inc
index c3814842e0..b3527e7361 100644
--- a/meta/packages/apt/apt-native.inc
+++ b/meta/packages/apt/apt-native.inc
@@ -1,7 +1,7 @@
require apt.inc
inherit native
-DEPENDS += "dpkg-native curl-native db-native gettext-native"
+DEPENDS += "dpkg-native gettext-native"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/apt-${PV}"
PACKAGES = ""
USE_NLS = "yes"
@@ -37,7 +37,6 @@ do_stage_base () {
install -m 0755 bin/apt-get ${bindir}/
install -m 0755 bin/apt-config ${bindir}/
install -m 0755 bin/apt-cache ${bindir}/
- install -m 0755 bin/apt-ftparchive ${bindir}/
install -m 0755 bin/apt-sortpkgs ${bindir}/
install -m 0755 bin/apt-extracttemplates ${bindir}/
diff --git a/meta/packages/apt/apt-native_0.7.14.bb b/meta/packages/apt/apt-native_0.7.14.bb
index ef8decc748..268e9df720 100644
--- a/meta/packages/apt/apt-native_0.7.14.bb
+++ b/meta/packages/apt/apt-native_0.7.14.bb
@@ -1,6 +1,7 @@
require apt-native.inc
-PR = "r1"
+PR = "r2"
SRC_URI += "file://nodoc.patch;patch=1 \
- file://noconfigure.patch;patch=1"
+ file://noconfigure.patch;patch=1 \
+ file://no-curl.patch;patch=1"
diff --git a/meta/packages/apt/files/no-curl.patch b/meta/packages/apt/files/no-curl.patch
new file mode 100644
index 0000000000..4e07c8f2dc
--- /dev/null
+++ b/meta/packages/apt/files/no-curl.patch
@@ -0,0 +1,44 @@
+---
+ configure.in | 6 ------
+ methods/makefile | 7 -------
+ 2 files changed, 13 deletions(-)
+
+--- apt-0.7.14.orig/configure.in
++++ apt-0.7.14/configure.in
+@@ -84,16 +84,10 @@ AC_CHECK_HEADER(db.h,
+ )]
+ )
+
+ LIBS="$saveLIBS"
+
+-AC_CHECK_LIB(curl, curl_easy_init,
+- [AC_CHECK_HEADER(curl/curl.h,
+- curl_ok=yes,
+- curl_ok=no)],
+- AC_MSG_ERROR([failed: I need CURL due https support]),
+-)
+
+ AC_SUBST(BDBLIB)
+
+ dnl Converts the ARCH to be something singular for this general CPU family
+ dnl This is often the dpkg architecture string.
+--- apt-0.7.14.orig/methods/makefile
++++ apt-0.7.14/methods/makefile
+@@ -50,17 +50,10 @@ PROGRAM=http
+ SLIBS = -lapt-pkg $(SOCKETLIBS)
+ LIB_MAKES = apt-pkg/makefile
+ SOURCE = http.cc rfc2553emu.cc connect.cc
+ include $(PROGRAM_H)
+
+-# The https method
+-PROGRAM=https
+-SLIBS = -lapt-pkg -lcurl
+-LIB_MAKES = apt-pkg/makefile
+-SOURCE = https.cc
+-include $(PROGRAM_H)
+-
+ # The ftp method
+ PROGRAM=ftp
+ SLIBS = -lapt-pkg $(SOCKETLIBS)
+ LIB_MAKES = apt-pkg/makefile
+ SOURCE = ftp.cc rfc2553emu.cc connect.cc