summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Tian <kevin.tian@intel.com>2010-07-06 15:33:31 +0800
committerJoshua Lock <josh@linux.intel.com>2010-07-07 17:12:11 +0100
commitb56df3f573bdd5b5aebb5bdf565e8d9be1aa098d (patch)
treee3ad39ad14f6eb1f941445d35e7650113808e1bc
parent330e32da127715341f49780b1f88120a31411739 (diff)
downloadopenembedded-core-contrib-b56df3f573bdd5b5aebb5bdf565e8d9be1aa098d.tar.gz
busybox: upgrade to 1.16.2
[Patches] (add comments for kept patches) REMOVE _0000-wget-no-check-certificate.patch_: in 1.16.2 now KEEP _B921600.patch_: add 921600 speed serial line REMOVE _ash_fix_redirection_of_fd_0.patch_: in 1.16.2 REMOVE _fdisk_lineedit_segfault.patch_: not used even in 1.15.3 REMOVE _fix_: not used even in 1.15.3 KEEP _get_header_tar.patch_: fix tar problem with exact 100 bytes filename REMOVE _r24785.patch_: not used even in 1.15.3 KEEP _run-parts.in.usr-bin.patch_: solve confliction with debianutils. Though the later is not in poky, keep it for safety KEEP _udhcpscript.patch_: fix warning message REMOVE _xargs-double-size.patch_: not used even in 1.15.3 KEEP _busybox-appletlib-dependency.patch_: solve paralle make issue. Move away from files/. KEEP _udhcpc-fix-nfsroot.patch_: support nfsroot [Files] UPDATE _defconfig_: adapt to new 1.16.2 config options [Recipe] - adapt to new 1.16.2 config option - remove old OEMAKE_apend on "CROSS" which has been replaced by "CROSS_COMPILE" since 2006 Signed-off-by Kevin Tian <kevin.tian@intel.com>
-rw-r--r--meta/packages/busybox/busybox-1.15.3/0000-wget-no-check-certificate.patch12
-rw-r--r--meta/packages/busybox/busybox-1.15.3/ash_fix_redirection_of_fd_0.patch21
-rw-r--r--meta/packages/busybox/busybox-1.15.3/fdisk_lineedit_segfault.patch12
-rw-r--r--meta/packages/busybox/busybox-1.15.3/fix31
-rw-r--r--meta/packages/busybox/busybox-1.15.3/r24785.patch14
-rw-r--r--meta/packages/busybox/busybox-1.15.3/xargs-double-size.patch13
-rw-r--r--meta/packages/busybox/busybox-1.16.2/B921600.patch (renamed from meta/packages/busybox/busybox-1.15.3/B921600.patch)9
-rw-r--r--meta/packages/busybox/busybox-1.16.2/busybox-appletlib-dependency.patch35
-rw-r--r--meta/packages/busybox/busybox-1.16.2/defconfig (renamed from meta/packages/busybox/busybox-1.15.3/defconfig)45
-rw-r--r--meta/packages/busybox/busybox-1.16.2/get_header_tar.patch (renamed from meta/packages/busybox/busybox-1.15.3/get_header_tar.patch)9
-rw-r--r--meta/packages/busybox/busybox-1.16.2/run-parts.in.usr-bin.patch (renamed from meta/packages/busybox/busybox-1.15.3/run-parts.in.usr-bin.patch)15
-rw-r--r--meta/packages/busybox/busybox-1.16.2/udhcpc-fix-nfsroot.patch (renamed from meta/packages/busybox/busybox-1.15.3/udhcpc-fix-nfsroot.patch)8
-rw-r--r--meta/packages/busybox/busybox-1.16.2/udhcpscript.patch (renamed from meta/packages/busybox/busybox-1.15.3/udhcpscript.patch)9
-rw-r--r--meta/packages/busybox/busybox.inc5
-rw-r--r--meta/packages/busybox/busybox_1.15.3.bb28
-rw-r--r--meta/packages/busybox/busybox_1.16.2.bb24
-rw-r--r--meta/packages/busybox/files/busybox-appletlib-dependency.patch15
17 files changed, 144 insertions, 161 deletions
diff --git a/meta/packages/busybox/busybox-1.15.3/0000-wget-no-check-certificate.patch b/meta/packages/busybox/busybox-1.15.3/0000-wget-no-check-certificate.patch
deleted file mode 100644
index c737f172b1..0000000000
--- a/meta/packages/busybox/busybox-1.15.3/0000-wget-no-check-certificate.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/networking/wget.c b/networking/wget.c
-index 9d813dc..09edd67 100644
---- a/networking/wget.c
-+++ b/networking/wget.c
-@@ -546,6 +546,7 @@ int wget_main(int argc UNUSED_PARAM, char **argv)
- "passive-ftp\0" No_argument "\xff"
- "header\0" Required_argument "\xfe"
- "post-data\0" Required_argument "\xfd"
-+ "no-check-certificate\0" No_argument "\xfc"
- ;
- #endif
-
diff --git a/meta/packages/busybox/busybox-1.15.3/ash_fix_redirection_of_fd_0.patch b/meta/packages/busybox/busybox-1.15.3/ash_fix_redirection_of_fd_0.patch
deleted file mode 100644
index 5c791271e5..0000000000
--- a/meta/packages/busybox/busybox-1.15.3/ash_fix_redirection_of_fd_0.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Fix redirection of fd 0 in scripts sourced from interactive ash
-
-Based on Busybox git 08d8b3cee1329d390f91bce419e2b4dadf484952 by
-Denys Vlasenko <vda.linux@googlemail.com>.
-
-Can be removed when we bump to 1.16.1 + patches or later
-
-JL 03/06/10
-Index: busybox-1.15.3/shell/ash.c
-===================================================================
---- busybox-1.15.3.orig/shell/ash.c 2009-12-12 21:16:38.000000000 +0000
-+++ busybox-1.15.3/shell/ash.c 2010-06-03 09:44:59.484647637 +0100
-@@ -5071,7 +5071,7 @@
- return 0;
- pf = g_parsefile;
- while (pf) {
-- if (fd == pf->fd) {
-+ if (pf->fd > 0 && fd == pf->fd) {
- return 1;
- }
- pf = pf->prev;
diff --git a/meta/packages/busybox/busybox-1.15.3/fdisk_lineedit_segfault.patch b/meta/packages/busybox/busybox-1.15.3/fdisk_lineedit_segfault.patch
deleted file mode 100644
index 633153f1ce..0000000000
--- a/meta/packages/busybox/busybox-1.15.3/fdisk_lineedit_segfault.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- old/libbb/lineedit.c 2008/09/27 01:28:56 23530
-+++ new/libbb/lineedit.c 2008/11/02 00:41:05 23898
-@@ -1412,7 +1412,8 @@
- if ((state->flags & SAVE_HISTORY) && state->hist_file)
- load_history(state->hist_file);
- #endif
-- state->cur_history = state->cnt_history;
-+ if (state->flags & DO_HISTORY)
-+ state->cur_history = state->cnt_history;
-
- /* prepare before init handlers */
- cmdedit_y = 0; /* quasireal y, not true if line > xt*yt */
diff --git a/meta/packages/busybox/busybox-1.15.3/fix b/meta/packages/busybox/busybox-1.15.3/fix
deleted file mode 100644
index 544f41b256..0000000000
--- a/meta/packages/busybox/busybox-1.15.3/fix
+++ /dev/null
@@ -1,31 +0,0 @@
----
- util-linux/mdev.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
---- busybox-1.13.2.orig/util-linux/mdev.c
-+++ busybox-1.13.2/util-linux/mdev.c
-@@ -107,11 +107,11 @@ static void make_device(char *path, int
-
- #if ENABLE_FEATURE_MDEV_CONF
- parser = config_open2("/etc/mdev.conf", fopen_for_read);
-
- /* If we have config file, look up user settings */
-- while (config_read(parser, tokens, 4, 3, "# \t", PARSE_NORMAL)) {
-+ while (config_read(parser, tokens, 5, 3, "# \t", PARSE_NORMAL)) {
- regmatch_t off[1 + 9*ENABLE_FEATURE_MDEV_RENAME_REGEXP];
- char *val;
-
- /* Fields: regex uid:gid mode [alias] [cmd] */
-
-@@ -211,10 +211,11 @@ static void make_device(char *path, int
- }
- #endif /* ENABLE_FEATURE_MDEV_RENAME */
-
- #if ENABLE_FEATURE_MDEV_EXEC
- /* The rest (opt): command to run */
-+ val = tokens[4];
- if (!val)
- break;
- {
- const char *s = "@$*";
- const char *s2 = strchr(s, *val);
diff --git a/meta/packages/busybox/busybox-1.15.3/r24785.patch b/meta/packages/busybox/busybox-1.15.3/r24785.patch
deleted file mode 100644
index e3e80befcd..0000000000
--- a/meta/packages/busybox/busybox-1.15.3/r24785.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- busybox/util-linux/mdev.c 2009/01/08 17:19:01 24725
-+++ busybox/util-linux/mdev.c 2009/01/12 07:57:52 24785
-@@ -179,8 +179,9 @@
- unsigned i, n;
- #endif
- char *a = val;
-- s = strchr(val, ' ');
-- val = (s && s[1]) ? s+1 : NULL;
-+ s = strchrnul(val, ' ');
-+ val = (s[0] && s[1]) ? s+1 : NULL;
-+ s[0] = '\0';
- #if ENABLE_FEATURE_MDEV_RENAME_REGEXP
- /* substitute %1..9 with off[1..9], if any */
- n = 0;
diff --git a/meta/packages/busybox/busybox-1.15.3/xargs-double-size.patch b/meta/packages/busybox/busybox-1.15.3/xargs-double-size.patch
deleted file mode 100644
index df64554ffc..0000000000
--- a/meta/packages/busybox/busybox-1.15.3/xargs-double-size.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- busybox-1.2.1/findutils/xargs.c.org 2006-09-19 18:18:17.084592997 +0200
-+++ busybox-1.2.1/findutils/xargs.c 2006-09-19 18:18:09.820275793 +0200
-@@ -466,8 +466,8 @@
- have it at 1 meg). Things will work fine with a large ARG_MAX but it
- will probably hurt the system more than it needs to; an array of this
- size is allocated. */
-- if (orig_arg_max > 20 * 1024)
-- orig_arg_max = 20 * 1024;
-+ if (orig_arg_max > 40 * 1024)
-+ orig_arg_max = 40 * 1024;
- n_max_chars = orig_arg_max;
- }
- max_chars = xmalloc(n_max_chars);
diff --git a/meta/packages/busybox/busybox-1.15.3/B921600.patch b/meta/packages/busybox/busybox-1.16.2/B921600.patch
index 61cc32b0e5..803dc411d8 100644
--- a/meta/packages/busybox/busybox-1.15.3/B921600.patch
+++ b/meta/packages/busybox/busybox-1.16.2/B921600.patch
@@ -1,3 +1,12 @@
+# copy commit message from OE as the patch comment:
+# commit 5b1ed09b1ab1a60a28a76e4658bc9957cd361b5d
+# Author: Valentin Longchamp <valentin.longchamp@epfl.ch>
+# Date: Mon Dec 8 14:43:23 2008 +0100
+
+# busybox: added support for 921600 speed of serial line
+#
+# above comment added by Kevin Tian <kevin.tian@intel.com>, 2010-07-06
+
diff -upNr busybox-1.7.2/libbb/speed_table.c busybox-1.7.2-921600/libbb/speed_table.c
--- busybox-1.7.2/libbb/speed_table.c 2007-09-03 13:48:41.000000000 +0200
+++ busybox-1.7.2-921600/libbb/speed_table.c 2008-10-09 16:23:26.269592899 +0200
diff --git a/meta/packages/busybox/busybox-1.16.2/busybox-appletlib-dependency.patch b/meta/packages/busybox/busybox-1.16.2/busybox-appletlib-dependency.patch
new file mode 100644
index 0000000000..041aa6c54c
--- /dev/null
+++ b/meta/packages/busybox/busybox-1.16.2/busybox-appletlib-dependency.patch
@@ -0,0 +1,35 @@
+# copy commit message from OE as the patch comment:
+# commit 98c24291aa165f53423c27ae033831ce0b3bb676
+# Author: Roman I Khimov <khimov@altell.ru>
+# Date: Thu Mar 26 23:03:58 2009 +0000
+#
+# busybox: update appletlib dependency patch
+#
+# Previous version still failed from time to time on clean-start builds
+# with 4 bitbake threads and '-j16'. Building busybox as sole target worked
+# well.
+#
+# The reason is that previous version introduced a race between applets make
+# processes spawned from top-level Makefile and from libbb Makefile.
+#
+# Fix it with high-level dependency that doesn't create races.
+#
+# Signed-off-by: Koen Kooi <koen@openembedded.org>
+#
+# above comment added by Kevin Tian <kevin.tian@intel.com>, 2010-07-06
+
+Index: busybox-1.13.2/Makefile
+===================================================================
+--- busybox-1.13.2.orig/Makefile 2009-03-19 15:44:37.419270265 +0300
++++ busybox-1.13.2/Makefile 2009-03-19 15:45:57.737521296 +0300
+@@ -471,6 +471,10 @@
+ util-linux/ \
+ util-linux/volume_id/ \
+
++# Lib interdeps
++# libbb uses headers generated in applets
++libbb: applets
++
+ endif # KBUILD_EXTMOD
+
+ ifeq ($(dot-config),1)
diff --git a/meta/packages/busybox/busybox-1.15.3/defconfig b/meta/packages/busybox/busybox-1.16.2/defconfig
index c347c80d5b..431da94dd2 100644
--- a/meta/packages/busybox/busybox-1.15.3/defconfig
+++ b/meta/packages/busybox/busybox-1.16.2/defconfig
@@ -1,7 +1,7 @@
#
# Automatically generated make config: don't edit
-# Busybox version: 1.15.3
-# Tue Jun 1 14:34:32 2010
+# Busybox version: 1.16.2
+# Tue Jul 6 14:52:48 2010
#
CONFIG_HAVE_DOT_CONFIG=y
@@ -14,6 +14,8 @@ CONFIG_HAVE_DOT_CONFIG=y
#
# CONFIG_DESKTOP is not set
# CONFIG_EXTRA_COMPAT is not set
+# CONFIG_INCLUDE_SUSv2 is not set
+# CONFIG_USE_PORTABLE_CODE is not set
CONFIG_FEATURE_BUFFERS_USE_MALLOC=y
# CONFIG_FEATURE_BUFFERS_GO_ON_STACK is not set
# CONFIG_FEATURE_BUFFERS_GO_IN_BSS is not set
@@ -59,7 +61,6 @@ CONFIG_EXTRA_CFLAGS=""
CONFIG_NO_DEBUG_LIB=y
# CONFIG_DMALLOC is not set
# CONFIG_EFENCE is not set
-# CONFIG_INCLUDE_SUSv2 is not set
#
# Installation Options
@@ -120,6 +121,7 @@ CONFIG_CPIO=y
# CONFIG_FEATURE_DPKG_DEB_EXTRACT_ONLY is not set
CONFIG_GUNZIP=y
CONFIG_GZIP=y
+# CONFIG_FEATURE_GZIP_LONG_OPTIONS is not set
# CONFIG_LZOP is not set
# CONFIG_LZOP_COMPR_HIGH is not set
# CONFIG_RPM2CPIO is not set
@@ -133,6 +135,7 @@ CONFIG_FEATURE_TAR_FROM=y
CONFIG_FEATURE_TAR_GNU_EXTENSIONS=y
# CONFIG_FEATURE_TAR_LONG_OPTIONS is not set
# CONFIG_FEATURE_TAR_UNAME_GNAME is not set
+# CONFIG_FEATURE_TAR_NOPRESERVE_TIME is not set
# CONFIG_UNCOMPRESS is not set
# CONFIG_UNLZMA is not set
# CONFIG_FEATURE_LZMA_FAST is not set
@@ -148,15 +151,19 @@ CONFIG_CAT=y
CONFIG_CHGRP=y
CONFIG_CHMOD=y
CONFIG_CHOWN=y
+# CONFIG_FEATURE_CHOWN_LONG_OPTIONS is not set
CONFIG_CHROOT=y
# CONFIG_CKSUM is not set
# CONFIG_COMM is not set
CONFIG_CP=y
+# CONFIG_FEATURE_CP_LONG_OPTIONS is not set
CONFIG_CUT=y
CONFIG_DATE=y
# CONFIG_FEATURE_DATE_ISOFMT is not set
+CONFIG_FEATURE_DATE_COMPAT=y
CONFIG_DD=y
CONFIG_FEATURE_DD_SIGNAL_HANDLING=y
+# CONFIG_FEATURE_DD_THIRD_STATUS_LINE is not set
# CONFIG_FEATURE_DD_IBS_OBS is not set
CONFIG_DF=y
# CONFIG_FEATURE_DF_FANCY is not set
@@ -271,7 +278,7 @@ CONFIG_FEATURE_AUTOWIDTH=y
CONFIG_FEATURE_HUMAN_READABLE=y
#
-# Common options for md5sum, sha1sum
+# Common options for md5sum, sha1sum, sha256sum, sha512sum
#
CONFIG_FEATURE_MD5_SHA1_SUM_CHECK=y
@@ -318,9 +325,8 @@ CONFIG_AWK=y
# CONFIG_FEATURE_AWK_LIBM is not set
CONFIG_CMP=y
CONFIG_DIFF=y
-CONFIG_FEATURE_DIFF_BINARY=y
+# CONFIG_FEATURE_DIFF_LONG_OPTIONS is not set
CONFIG_FEATURE_DIFF_DIR=y
-# CONFIG_FEATURE_DIFF_MINIMAL is not set
# CONFIG_ED is not set
CONFIG_PATCH=y
CONFIG_SED=y
@@ -364,6 +370,7 @@ CONFIG_FEATURE_FIND_PRUNE=y
CONFIG_FEATURE_FIND_PATH=y
CONFIG_FEATURE_FIND_REGEX=y
# CONFIG_FEATURE_FIND_CONTEXT is not set
+# CONFIG_FEATURE_FIND_LINKS is not set
CONFIG_GREP=y
CONFIG_FEATURE_GREP_EGREP_ALIAS=y
CONFIG_FEATURE_GREP_FGREP_ALIAS=y
@@ -453,6 +460,7 @@ CONFIG_MODPROBE=y
# Options common to multiple modutils
#
# CONFIG_FEATURE_2_4_MODULES is not set
+# CONFIG_FEATURE_INSMOD_TRY_MMAP is not set
# CONFIG_FEATURE_INSMOD_VERSION_CHECKING is not set
# CONFIG_FEATURE_INSMOD_KSYMOOPS_SYMBOLS is not set
# CONFIG_FEATURE_INSMOD_LOADINKMEM is not set
@@ -488,12 +496,14 @@ CONFIG_FEATURE_FDISK_WRITABLE=y
# CONFIG_FINDFS is not set
# CONFIG_FREERAMDISK is not set
CONFIG_FSCK_MINIX=y
+# CONFIG_MKFS_EXT2 is not set
CONFIG_MKFS_MINIX=y
#
# Minix filesystem support
#
CONFIG_FEATURE_MINIX2=y
+# CONFIG_MKFS_REISER is not set
# CONFIG_MKFS_VFAT is not set
# CONFIG_GETOPT is not set
# CONFIG_FEATURE_GETOPT_LONG is not set
@@ -506,6 +516,8 @@ CONFIG_FEATURE_HWCLOCK_ADJTIME_FHS=y
# CONFIG_IPCRM is not set
# CONFIG_IPCS is not set
CONFIG_LOSETUP=y
+# CONFIG_LSPCI is not set
+# CONFIG_LSUSB is not set
# CONFIG_MDEV is not set
# CONFIG_FEATURE_MDEV_CONF is not set
# CONFIG_FEATURE_MDEV_RENAME is not set
@@ -518,6 +530,7 @@ CONFIG_MORE=y
CONFIG_FEATURE_USE_TERMIOS=y
# CONFIG_VOLUMEID is not set
# CONFIG_FEATURE_VOLUMEID_EXT is not set
+# CONFIG_FEATURE_VOLUMEID_BTRFS is not set
# CONFIG_FEATURE_VOLUMEID_REISERFS is not set
# CONFIG_FEATURE_VOLUMEID_FAT is not set
# CONFIG_FEATURE_VOLUMEID_HFS is not set
@@ -595,6 +608,7 @@ CONFIG_DC=y
# CONFIG_EJECT is not set
# CONFIG_FEATURE_EJECT_SCSI is not set
# CONFIG_FBSPLASH is not set
+# CONFIG_FLASHCP is not set
# CONFIG_FLASH_LOCK is not set
# CONFIG_FLASH_UNLOCK is not set
# CONFIG_FLASH_ERASEALL is not set
@@ -638,6 +652,7 @@ CONFIG_TIME=y
# CONFIG_TIMEOUT is not set
# CONFIG_TTYSIZE is not set
# CONFIG_VOLNAME is not set
+# CONFIG_WALL is not set
# CONFIG_WATCHDOG is not set
#
@@ -657,6 +672,7 @@ CONFIG_FEATURE_PREFER_IPV4_ADDRESS=y
# CONFIG_FAKEIDENTD is not set
# CONFIG_FTPD is not set
# CONFIG_FEATURE_FTP_WRITE is not set
+# CONFIG_FEATURE_FTPD_ACCEPT_BROKEN_LIST is not set
# CONFIG_FTPGET is not set
# CONFIG_FTPPUT is not set
# CONFIG_FEATURE_FTPGETPUT_LONG_OPTIONS is not set
@@ -722,6 +738,8 @@ CONFIG_NETSTAT=y
# CONFIG_FEATURE_NETSTAT_WIDE is not set
# CONFIG_FEATURE_NETSTAT_PRG is not set
CONFIG_NSLOOKUP=y
+# CONFIG_NTPD is not set
+# CONFIG_FEATURE_NTPD_SERVER is not set
CONFIG_PING=y
CONFIG_PING6=y
CONFIG_FEATURE_FANCY_PING=y
@@ -733,22 +751,25 @@ CONFIG_TELNET=y
CONFIG_FEATURE_TELNET_AUTOLOGIN=y
# CONFIG_TELNETD is not set
# CONFIG_FEATURE_TELNETD_STANDALONE is not set
+# CONFIG_FEATURE_TELNETD_INETD_WAIT is not set
CONFIG_TFTP=y
# CONFIG_TFTPD is not set
CONFIG_FEATURE_TFTP_GET=y
CONFIG_FEATURE_TFTP_PUT=y
# CONFIG_FEATURE_TFTP_BLOCKSIZE is not set
+# CONFIG_FEATURE_TFTP_PROGRESS_BAR is not set
# CONFIG_TFTP_DEBUG is not set
CONFIG_TRACEROUTE=y
+# CONFIG_TRACEROUTE6 is not set
# CONFIG_FEATURE_TRACEROUTE_VERBOSE is not set
# CONFIG_FEATURE_TRACEROUTE_SOURCE_ROUTE is not set
# CONFIG_FEATURE_TRACEROUTE_USE_ICMP is not set
-CONFIG_APP_UDHCPD=y
-# CONFIG_APP_DHCPRELAY is not set
-CONFIG_APP_DUMPLEASES=y
+CONFIG_UDHCPD=y
+# CONFIG_DHCPRELAY is not set
+CONFIG_DUMPLEASES=y
# CONFIG_FEATURE_UDHCPD_WRITE_LEASES_EARLY is not set
CONFIG_DHCPD_LEASES_FILE="/var/lib/misc/udhcpd.leases"
-CONFIG_APP_UDHCPC=y
+CONFIG_UDHCPC=y
CONFIG_FEATURE_UDHCPC_ARPING=y
# CONFIG_FEATURE_UDHCP_PORT is not set
CONFIG_UDHCP_DEBUG=0
@@ -813,6 +834,7 @@ CONFIG_FEATURE_TOP_CPU_GLOBAL_PERCENTS=y
# CONFIG_FEATURE_TOP_DECIMALS is not set
# CONFIG_FEATURE_TOP_SMP_PROCESS is not set
# CONFIG_FEATURE_TOPMEM is not set
+# CONFIG_FEATURE_SHOW_THREADS is not set
CONFIG_UPTIME=y
CONFIG_WATCH=y
@@ -855,8 +877,6 @@ CONFIG_FEATURE_SH_IS_ASH=y
CONFIG_ASH=y
CONFIG_ASH_BASH_COMPAT=y
CONFIG_ASH_JOB_CONTROL=y
-CONFIG_ASH_READ_NCHARS=y
-CONFIG_ASH_READ_TIMEOUT=y
CONFIG_ASH_ALIAS=y
CONFIG_ASH_GETOPTS=y
CONFIG_ASH_BUILTIN_ECHO=y
@@ -879,6 +899,7 @@ CONFIG_ASH_EXPAND_PRMT=y
# CONFIG_HUSH_FUNCTIONS is not set
# CONFIG_HUSH_LOCAL is not set
# CONFIG_HUSH_EXPORT_N is not set
+# CONFIG_HUSH_RANDOM_SUPPORT is not set
# CONFIG_LASH is not set
# CONFIG_MSH is not set
CONFIG_SH_MATH_SUPPORT=y
diff --git a/meta/packages/busybox/busybox-1.15.3/get_header_tar.patch b/meta/packages/busybox/busybox-1.16.2/get_header_tar.patch
index 0121cd1b61..bc9b427ea9 100644
--- a/meta/packages/busybox/busybox-1.15.3/get_header_tar.patch
+++ b/meta/packages/busybox/busybox-1.16.2/get_header_tar.patch
@@ -1,3 +1,12 @@
+# copy commit message from OE as the patch comment:
+# commit 5a0e1d473ca7aca5ffefffe9a2ec44ae7a1f35bc
+# Author: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
+# Date: Wed Feb 11 22:40:21 2009 +0100
+#
+# busybox: fix tar problem with filenames that are exactly 100 bytes
+#
+# above comment added by Kevin Tian <kevin.tian@intel.com>, 2010-07-06
+
--- busybox-1.13.2/archival/libunarchive/get_header_tar.c.orig 2008-11-09 18:28:02.000000000 +0100
+++ busybox-1.13.2/archival/libunarchive/get_header_tar.c 2009-02-11 22:34:52.000000000 +0100
@@ -252,6 +252,8 @@
diff --git a/meta/packages/busybox/busybox-1.15.3/run-parts.in.usr-bin.patch b/meta/packages/busybox/busybox-1.16.2/run-parts.in.usr-bin.patch
index 6f209ce571..bedb974432 100644
--- a/meta/packages/busybox/busybox-1.15.3/run-parts.in.usr-bin.patch
+++ b/meta/packages/busybox/busybox-1.16.2/run-parts.in.usr-bin.patch
@@ -1,3 +1,18 @@
+# copy commit message from OE as the patch comment:
+# commit f1b326c83be0d95571b991d8d2ee239982380b6b
+# Author: Martin Jansa <Martin.Jansa@gmail.com>
+# Date: Fri Apr 30 15:37:38 2010 +0200
+#
+# busybox: add patch for installing run-parts to /usr/bin/ instead of /bin
+#
+# * otherwise debianutils install will fail with
+# update-alternatives: Error: cannot register alternative run-parts to /usr/bin/run-parts since it is
+#
+# Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+#
+# Poky doesn't have debianutils, but let's keep it for safety
+# above comment added by Kevin Tian <kevin.tian@intel.com>, 2010-07-06
+
diff -uNr busybox-1.15.3.orig//include/applets.h busybox-1.15.3/include/applets.h
--- busybox-1.15.3.orig//include/applets.h 2009-12-12 22:13:28.000000000 +0100
+++ busybox-1.15.3/include/applets.h 2010-04-30 15:35:40.000000000 +0200
diff --git a/meta/packages/busybox/busybox-1.15.3/udhcpc-fix-nfsroot.patch b/meta/packages/busybox/busybox-1.16.2/udhcpc-fix-nfsroot.patch
index edea898b10..89eeb425ad 100644
--- a/meta/packages/busybox/busybox-1.15.3/udhcpc-fix-nfsroot.patch
+++ b/meta/packages/busybox/busybox-1.16.2/udhcpc-fix-nfsroot.patch
@@ -1,3 +1,11 @@
+# copy commit message from OE as the patch comment:
+# commit ec4da6df3ad5b8b03446d0dda9c50a2439ae325a
+# Author: Denys Dmytriyenko <denis@denix.org>
+# Date: Wed Feb 4 11:43:18 2009 -0500
+#
+# busybox: fix nfsroot issues with resetting IP and deleting routes
+#
+# above comment added by Kevin Tian <kevin.tian@intel.com>, 2010-07-06
Index: busybox-1.15.3/examples/udhcp/simple.script
===================================================================
--- busybox-1.15.3.orig/examples/udhcp/simple.script 2010-06-27 12:17:14.116876946 +0200
diff --git a/meta/packages/busybox/busybox-1.15.3/udhcpscript.patch b/meta/packages/busybox/busybox-1.16.2/udhcpscript.patch
index 2ffba956ae..81bca634af 100644
--- a/meta/packages/busybox/busybox-1.15.3/udhcpscript.patch
+++ b/meta/packages/busybox/busybox-1.16.2/udhcpscript.patch
@@ -1,3 +1,12 @@
+# copy commit message from OE as the patch comment
+# commit c9bb6478a873d6de4c8a0e712435ac9a658a345d
+# Author: Holger Schurig <schurig@mn-solutions.de>
+# Date: Wed Sep 29 08:29:58 2004 +0000
+#
+# udhcpscript: fixes the "deleting routers" error message in case of no existing default routes
+#
+# Above comment added by Kevin Tian <kevin.tian@intel.com>, 2010-07-06
+
Index: busybox-1.15.1/examples/udhcp/simple.script
===================================================================
--- busybox-1.15.1.orig/examples/udhcp/simple.script 2009-09-12 17:55:36.000000000 +0200
diff --git a/meta/packages/busybox/busybox.inc b/meta/packages/busybox/busybox.inc
index 9f450532da..8c258135c8 100644
--- a/meta/packages/busybox/busybox.inc
+++ b/meta/packages/busybox/busybox.inc
@@ -7,7 +7,6 @@ SECTION = "base"
PRIORITY = "required"
export EXTRA_CFLAGS = "${CFLAGS}"
-EXTRA_OEMAKE_append = " CROSS=${HOST_PREFIX}"
PACKAGES =+ "${PN}-httpd ${PN}-udhcpd"
FILES_${PN}-httpd = "${sysconfdir}/init.d/busybox-httpd /srv/www"
@@ -70,7 +69,7 @@ do_install () {
install -m 0755 ${WORKDIR}/busybox-httpd ${D}${sysconfdir}/init.d/
install -d ${D}/srv/www
fi
- if grep "CONFIG_APP_UDHCPD=y" ${WORKDIR}/defconfig; then
+ if grep "CONFIG_UDHCPD=y" ${WORKDIR}/defconfig; then
# Move udhcpd back to /usr/sbin/udhcpd
install -d ${D}${sbindir}
mv ${D}/busybox${sbindir}/udhcpd ${D}${sbindir}/
@@ -84,7 +83,7 @@ do_install () {
install -m 0755 ${WORKDIR}/hwclock.sh ${D}${sysconfdir}/init.d/
fi
- if grep "CONFIG_APP_UDHCPC=y" ${WORKDIR}/defconfig; then
+ if grep "CONFIG_UDHCPC=y" ${WORKDIR}/defconfig; then
# Move dhcpc back to /usr/sbin/udhcpc
install -d ${D}${base_sbindir}
mv ${D}/busybox${base_sbindir}/udhcpc ${D}${base_sbindir}/
diff --git a/meta/packages/busybox/busybox_1.15.3.bb b/meta/packages/busybox/busybox_1.15.3.bb
deleted file mode 100644
index 9be4abdb17..0000000000
--- a/meta/packages/busybox/busybox_1.15.3.bb
+++ /dev/null
@@ -1,28 +0,0 @@
-require busybox.inc
-PR = "r5"
-
-SRC_URI = "\
- http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
- file://udhcpscript.patch \
- file://udhcpc-fix-nfsroot.patch \
- file://B921600.patch \
- file://get_header_tar.patch \
- file://busybox-appletlib-dependency.patch \
- file://0000-wget-no-check-certificate.patch \
- file://run-parts.in.usr-bin.patch \
- file://ash_fix_redirection_of_fd_0.patch \
- file://find-touchscreen.sh \
- file://busybox-cron \
- file://busybox-httpd \
- file://busybox-udhcpd \
- file://default.script \
- file://simple.script \
- file://hwclock.sh \
- file://mount.busybox \
- file://syslog \
- file://syslog.conf \
- file://umount.busybox \
- file://defconfig \
-"
-
-EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX}"
diff --git a/meta/packages/busybox/busybox_1.16.2.bb b/meta/packages/busybox/busybox_1.16.2.bb
new file mode 100644
index 0000000000..0952f4ddb0
--- /dev/null
+++ b/meta/packages/busybox/busybox_1.16.2.bb
@@ -0,0 +1,24 @@
+require busybox.inc
+PR = "r0"
+
+SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
+ file://udhcpscript.patch \
+ file://udhcpc-fix-nfsroot.patch \
+ file://B921600.patch \
+ file://get_header_tar.patch \
+ file://busybox-appletlib-dependency.patch \
+ file://run-parts.in.usr-bin.patch \
+ file://find-touchscreen.sh \
+ file://busybox-cron \
+ file://busybox-httpd \
+ file://busybox-udhcpd \
+ file://default.script \
+ file://simple.script \
+ file://hwclock.sh \
+ file://mount.busybox \
+ file://syslog \
+ file://syslog.conf \
+ file://umount.busybox \
+ file://defconfig"
+
+EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX}"
diff --git a/meta/packages/busybox/files/busybox-appletlib-dependency.patch b/meta/packages/busybox/files/busybox-appletlib-dependency.patch
deleted file mode 100644
index 3efd4c0882..0000000000
--- a/meta/packages/busybox/files/busybox-appletlib-dependency.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Index: busybox-1.13.2/Makefile
-===================================================================
---- busybox-1.13.2.orig/Makefile 2009-03-19 15:44:37.419270265 +0300
-+++ busybox-1.13.2/Makefile 2009-03-19 15:45:57.737521296 +0300
-@@ -471,6 +471,10 @@
- util-linux/ \
- util-linux/volume_id/ \
-
-+# Lib interdeps
-+# libbb uses headers generated in applets
-+libbb: applets
-+
- endif # KBUILD_EXTMOD
-
- ifeq ($(dot-config),1)