summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhil Blundell <pb@pbcl.net>2011-07-07 17:02:24 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-12 15:16:09 +0100
commita78b644a8aebd078b9cc51bf7d102feef8191d95 (patch)
tree53a5075ae76677c199b0d65d1686100b817056f7
parent01e372559052aa348ceced07540fdb774d292c65 (diff)
downloadopenembedded-core-contrib-a78b644a8aebd078b9cc51bf7d102feef8191d95.tar.gz
kernel.bbclass, task-base: remove references to obsolete bluez-dtl1-workaround
Signed-off-by: Phil Blundell <philb@gnu.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/classes/kernel.bbclass5
-rw-r--r--meta/recipes-core/tasks/task-base.bb5
2 files changed, 0 insertions, 10 deletions
diff --git a/meta/classes/kernel.bbclass b/meta/classes/kernel.bbclass
index 1a71df64ba..e441748bf8 100644
--- a/meta/classes/kernel.bbclass
+++ b/meta/classes/kernel.bbclass
@@ -243,11 +243,6 @@ ALLOW_EMPTY_kernel = "1"
ALLOW_EMPTY_kernel-base = "1"
ALLOW_EMPTY_kernel-image = "1"
-# Userspace workarounds for kernel modules issues
-# This is shame, fix the kernel instead!
-DEPENDS_kernel-module-dtl1-cs = "bluez-dtl1-workaround"
-RDEPENDS_kernel-module-dtl1-cs = "bluez-dtl1-workaround"
-
pkg_postinst_kernel-image () {
if [ ! -e "$D/lib/modules/${KERNEL_VERSION}" ]; then
mkdir -p $D/lib/modules/${KERNEL_VERSION}
diff --git a/meta/recipes-core/tasks/task-base.bb b/meta/recipes-core/tasks/task-base.bb
index 97a854c2ef..99b7e17a69 100644
--- a/meta/recipes-core/tasks/task-base.bb
+++ b/meta/recipes-core/tasks/task-base.bb
@@ -80,7 +80,6 @@ RDEPENDS_task-base = "\
${@base_contains('COMBINED_FEATURES', 'irda', 'task-base-irda', '',d)} \
${@base_contains('COMBINED_FEATURES', 'pci', 'task-base-pci', '',d)} \
${@base_contains('COMBINED_FEATURES', 'pcmcia', 'task-base-pcmcia', '',d)} \
- ${@base_contains('COMBINED_FEATURES', 'pcmcia', 'bluez-dtl1-workaround', '',d)} \
${@base_contains('COMBINED_FEATURES', 'usbgadget', 'task-base-usbgadget', '',d)} \
${@base_contains('COMBINED_FEATURES', 'usbhost', 'task-base-usbhost', '',d)} \
${@base_contains('COMBINED_FEATURES', 'bluetooth', 'task-base-bluetooth', '',d)} \
@@ -99,7 +98,6 @@ RDEPENDS_task-base = "\
${@base_contains('DISTRO_FEATURES', 'raid', 'task-base-raid', '',d)} \
${@base_contains('DISTRO_FEATURES', 'zeroconf', 'task-base-zeroconf', '',d)} \
"
-# bluez-dtl1-workaround above is workaround for bitbake not handling DEPENDS on it in
RRECOMMENDS_task-base = "\
@@ -229,10 +227,7 @@ RRECOMMENDS_task-base-bluetooth = "\
${@base_contains('COMBINED_FEATURES', 'pcmcia', 'kernel-module-bluecard-cs', '',d)} \
${@base_contains('COMBINED_FEATURES', 'pcmcia', 'kernel-module-bluetoothuart-cs', '',d)} \
${@base_contains('COMBINED_FEATURES', 'pcmcia', 'kernel-module-dtl1-cs', '',d)} \
- ${@base_contains('COMBINED_FEATURES', 'pcmcia', 'bluez-dtl1-workaround', '',d)} \
"
-# bluez-dtl1-workaround above is workaround for bitbake not handling DEPENDS on it in
-# kernel.bbclass. It should be there as long as kernel-module-dtl1-cs is, but not longer.
RDEPENDS_task-base-irda = "\
irda-utils"